after Leopard install, printer won't scan!

Discussion in 'macOS' started by ero87, Oct 31, 2007.

  1. ero87 macrumors 65816

    ero87

    Joined:
    Jan 17, 2006
    Location:
    New York City
    #1
    Hey friends,

    So I've installed Leopard, but now when I try to scan with my HP PSC 1610 all-in-one, this error message is displayed on the printer's mini-screen thing:

    No Scan Options
    You need to install or run device software for feature.


    Any ideas how to fix this? Thanks so much :)
     
  2. kresh macrumors 6502a

    kresh

    #2
    I had a similar issue with my HP PSC 1400.

    I went to preferences --> Printer and added a new printer. Lo and behold when it asked which driver to use for the PSC 1400 there was a hyper-link asking to upgrade software. (The printer software update did not show up when I tried do an update through the menu bar.)

    It did a mini-software update and downloaded new drivers from HP.


    Hope this helps.
     
  3. sfdsels macrumors newbie

    Joined:
    Nov 4, 2007
    Location:
    Houston
    #3
    Same 1610 problem here -- no scanner



    I have the exact same problem. I reinstalled the HP software, but that does not seem to work. Called Apple, and they say to be on the look out for / contact the HP people. So in the meanwhile, I have no scanner. I should have listened to some of the experts who said to wait before buying Leopard and let others find out about the problems. :(
     
  4. Mindflux macrumors 68000

    Mindflux

    Joined:
    Oct 20, 2007
    Location:
    Austin
    #4
    My scanner software install after Leopard would not install. worked fine in Tiger. hope HP has a fix soon!
     
  5. ero87 thread starter macrumors 65816

    ero87

    Joined:
    Jan 17, 2006
    Location:
    New York City
    #5
    download the latest software from the webiste, it comes with a scanning app. I still can't get it to scan simply by pressing "Scan" on the printer, now I have to open the app... but it works!
     
  6. mommamoody macrumors newbie

    Joined:
    Mar 12, 2008
    #6
    Yes it works, its a huge file, but I downloaded the software package for 10.5 and after installing choose the scan application and it worked.
     
  7. pink tree macrumors newbie

    Joined:
    Aug 10, 2008
    Location:
    london
    #7
    after leopard, canon won't scan properly

    you lucky hp-bods!

    my canon 8000F no longer scans after installing leopard. i downloaded canoscan toolbox 4.1.3.0 from the canon site. only problem is that it is dated 2003 and doesn't work with leopard either.

    anyone know where i'd find a driver? reluctant to trash perfectly good scanner.
     
  8. drbryancarter1 macrumors newbie

    Joined:
    Nov 22, 2010
    #8
    Scanner problems since upgrading to OSX Snow Leopard

    Since upgrading to OS X Snow Leopard, the scan option on my HP Officejet J6450 window give the message "No Scan Options" and tells me to check the device manual. The manual does not help at all or discuss this message. Any suggestions?
     

Share This Page