After the 4.2.1 update my iPhone is stuck is recovery mode - includes solution

Discussion in 'iPhone Tips, Help and Troubleshooting' started by MaTiCeK, Nov 23, 2010.

  1. MaTiCeK macrumors member

    Joined:
    Apr 15, 2006
    #1
    I ran into some problems with the 4.2.1 iOS update. After the update iTunes presented me with the error 1013 popup and sent my iPhone into (permanent) recovery mode.
    Being an ex jailbrek user, I remembered a tool called iRecovery, that could bring iPhones out of recovery mode after a 10XX error. And while googling for it, I found an app called RecBoot, that does the same, but with GUI. Sure enough, I've downloaded it and a minute later my iPhone was out of recovery and updated to 4.2.1. Miracle!

    So if your iPhone gets stuck in recovery after the update, just give RecBoot a try.


    For clarification's sake, I'm using a non jailbroken iPhone 4 and Mac OS X 10.6.5. And I have no clue what so ever, why I had issues with the 4.2.1 update. Never before have I expirenced iTunes behave like this! ;)
     
  2. vlj9r macrumors member

    Joined:
    Feb 18, 2007
    #2
    another solution is to look inside your host file and delete any reference to gs.apple.com. You can rem the line out by placing a # sign in front of the ip address or simply delete the entire line.
     
  3. orpheus1120 macrumors 65816

    orpheus1120

    Joined:
    Jan 23, 2008
    Location:
    Malaysia
    #3
    I only have this issue when using non-Apple data cables. Official cables don't have this problem for me.
     
  4. MaTiCeK thread starter macrumors member

    Joined:
    Apr 15, 2006
    #4
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_2_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C148 Safari/6533.18.5)

    I already had Apple servers blocked in the host file, maybe this was this was the issue, however none of the betas on my ipad caused this problem with same host settings.

    Oh and yes I wasn't using Apple's cable, but don't see how this could be tge problem, firmware got installed correctly the iPhone just didn't boot out of recovery.
     
  5. solarnum macrumors newbie

    Joined:
    Nov 26, 2010
    #5
    iPhone 3GS stuck stubbornly in recovery mode

    I have a 3GS iphone that catastrophically stopped working a couple of days ago. First it lost cell coverage then said it couldn't find the network. I tried turning it off and on again, which promptly sent it into a reboot and then into recovery mode requesting connection to itunes. Inconvenient but did so, but then it would not restore the iPhone and needed to update from iTunes and downloaded iOS 4.2. This ended in a error message (1005) saying that the restore could not be completed. I tried several times to no avail.

    Since then I have followed a bunch of suggestions about using iRecovery (made no difference), tried winding back the firmware (your device is not compatible with this - WTF? I tried 3.1.3 and 4.1 and got nowhere). Tried RecBoot. Still nothing.

    I have the original error file (before I started iRecovery etc.) and am not familiar enough with it to spot an error (too long to post here, appended as an attachment . . . ). I'm not sure what caused the device to fail - whether I am in some firmware quagmire that can be fixed, or whether there is a hardware problem.

    Device is conveniently outside of the warranty period by a couple of months. Any help would be much appreciated!
     

    Attached Files:

Share This Page