After updating to iOS 7 APN settings will not save

Discussion in 'iOS 7' started by sordan, Sep 19, 2013.

  1. sordan macrumors member

    Apr 26, 2011
    I use an unlocked iPhone 4 with a prepaid data only SIM from b-mobile (Japan) that you have to enter in specific APN/user/pass info for it to connect to the network. After updating to iOS 7 it erased the APN settings and when I type them again then exit, and then re-enter settings, the things i typed disappeared.

    I tried resetting the network settings as well as doing a profile with the iPhone configuration thing. Still no luck.

    Any ideas?
  2. mrmamon macrumors newbie

    Sep 19, 2013
    I got solution.
    First turn off -> insert other sim(in my case docomo sim)-> turn on -> wait til it found signal -> swap sim with bmobile sim -> done!
    it's working
    may be ios7 bug or bmobile sim is not compatible, whatever this method work. be careful if you restart the phone, you have to do every step again.
  3. mgill macrumors newbie

    Sep 19, 2013
    Solution didn't work


    I have the same problem, once i upgraded to IOS7 i cannot put in the cellular data information, it dissapears once i do it for my bmobile data only sim card

    I have contacted docomo but they don't have any idea. Any other suggestions?
  4. gaffneyn macrumors newbie

    Sep 20, 2013
    Had exactly the same issue (iPhone 4 GSM, b-mobile Japanese SIM).

    Not the solution you want to hear, but I reverted to iOS 6.1.3 - seems to work ok once more. As I understand apple only allows reversion for a limited period of time, you might want to consider reverting while still possible, and let the early adopters iron out the iOS7 bugs.
  5. mgill macrumors newbie

    Sep 19, 2013
  6. gaffneyn macrumors newbie

    Sep 20, 2013
    @mgill - check the link in my post. That's what it's there for. ;)
  7. Winter2013 macrumors newbie

    Sep 23, 2013
    Hi I had the same issue with the settings not appearing to be changed but after I re-booted the phone the settings I typed in were now changed and correct.
  8. Jahin14 macrumors newbie

    Sep 22, 2013
    I have the same problem on my phone, I'm on giffgaff and every time I apply the settings they just reset and doesn't save
  9. rosujin macrumors newbie

    Mar 2, 2010
    B-Mobile Updated Device Support Info

    For some reason, B-Mobile does not support the iPhone 4 or iPad 2 with iOS7 installed. In their newly-updated "Supported Devices" statement, they specify that those two devices will only work with iOS6.

    Here is the statement:

    Newer devices (iPhone 4s, 5, 5s, 5c) and (iPad 3, 4) seem to work on B-Mobile with iOS7.

    I can't figure out what's unique about these two devices (iPhone 4 and iPad 2) where a software update makes them incompatible. Any ideas?
  10. zigital macrumors newbie

    Sep 24, 2013
    I would like to ask about IPAD MINI with IOS 7. Can they use with B-mobile?

    thank you
  11. rosujin macrumors newbie

    Mar 2, 2010
    Good question. The b-mobile site makes no mention of iPad Mini with iOS7. I would guess that it would work since it meets all of the communication standards of the current, full sized iPad with the micro SIM. Maybe they haven't tested one yet.
  12. b3tor, Sep 25, 2013
    Last edited: Sep 25, 2013

    b3tor macrumors newbie

    Sep 25, 2013
    According to the Japanese page
    and google translate, it appears that the work around is to insert another VOICE SIM card in the phone, change and save the APN, then put the B Mobile card back in. The APN may still disappear for no reason after you have done this. So I guess you keep that Voice SIM around at all time.

    Note that not all Voice SIM cards allow editing of APN . Some providers block this function on their SIMs.
  13. jlynn29 macrumors newbie

    Sep 26, 2013
    Try going to this site on your phone then on the bottom "create apn". Country : Japan . There should be most of the APN settings for bmobile that you could install on your phone. This worked for me. :)

    Also, if your APN isn't listed, just send them an email. They just added bmobile pair for me. Hope this helps!
  14. b3tor macrumors newbie

    Sep 25, 2013
    Ah yes... I forgot about the APN changer (Post #13). That should be the easiest solution.
  15. falloutmike macrumors newbie

    Jan 2, 2013
    I have u300 and selected the bmobile@u300
    downloaded the profile
    and turned off/on my phone
    still not working.

    Is there anything I am missing to do?

    Any other options. This starting to get very difficult ;(
  16. jlynn29, Sep 27, 2013
    Last edited: Sep 27, 2013

    jlynn29 macrumors newbie

    Sep 26, 2013
    There are 2 different settings for bmobile u300.

    B-Mobile (U-300)
    B-Mobile (bmobile@u300)

    Have you tried both? Does the APN match the one you are trying to install? If it's neither you may need to e-mail them to add the right one for you. You can check it here
  17. falloutmike, Sep 27, 2013
    Last edited: Sep 27, 2013

    falloutmike macrumors newbie

    Jan 2, 2013
    I have

    I created the apn then clicked install.

    Is it then supposed to work right away?
    Or do I need to adjust any other settings.

    my apn settings previously were
    username: bmobile@u300
    PW bmobile

    Is there a place i can put in the password?

    The problem is whenever I try to go into the settings and edit the apn again there is no save button. So everything just erases as soon as click back to cellular data network
  18. jlynn29, Sep 28, 2013
    Last edited: Sep 28, 2013

    jlynn29 macrumors newbie

    Sep 26, 2013
    The PW is already added in to it. It works for my husband and he had the same problem. He also has an iPhone 4 unlocked with ISO 7.
    It should work after a few minutes. To make sure it's installed check your settings > general >profile . Do not put anything in the apn setting where you would usually put it. This completely takes it's place. Turn off wifi and it should work. If you need to, try turning your phone off then on.
  19. falloutmike macrumors newbie

    Jan 2, 2013

    I did the same thing... with same phone and everything
    wonder what the problem is
  20. falloutmike macrumors newbie

    Jan 2, 2013
  21. b3tor macrumors newbie

    Sep 25, 2013
    Sometimes it's very finicky for the card to start working. Earlier this year I had to power cycle the phone to get it to work.

    Most recently (2 weeks ago, another card) it wouldn't work whether it's iPhone or Android phone. Then I entered APN info for the personal hotspot section just below and it started to work. I don't know if it's that or just that it takes 30 minutes for the card to register this time.

    Network connection however was immediate upon card insertion, evidenced by the NTT Docomo network identifiation, just that data took a long time to start to work.
  22. baharezo, Oct 25, 2013
    Last edited: Oct 26, 2013

    baharezo macrumors newbie

    Oct 25, 2013
    I just encountered the same problem here in Japan last night,
    fortunately I found this thread and it was really helpful.

    I am using iPhone4 with iOS7.03,
    the method I solved this apn setting problem is by using both solutions mentioned in the thread.

    First I have tried using apn changer from wifi, did not work.
    The method that actually worked was

    1. reset network settings to make sure I have a blank profile
    2. use my original sim to connect to the apn changer site (which will takes a bit international data roaming fee)
    make sure to choose docomo Japan as roaming service provider, this may matter since bmobile will be using docomo as well.
    3. apply profile provided by the apn changer(loses internet connection)
    4. swap to the bmobile sim

    by this time, my phone shows "no service 3G", but it is actually online,
    thanks everyone who contributed to this thread, you guys were really helpful.
  23. DarkShadowIB macrumors newbie

    Oct 26, 2013

    I have the same problem with IPhone 5S. After updating to IOS 7.0.3 from 7.0.2 the APN settings disappeared.

    I tried all clues and the last one was what baharezo suggested. I understand that when I access to roaming and unlockit... with my original sim I have to choose the japan b mobile settings and not the original settings.

    I tried that but my b mobile card still says "no service".

    What else could I try?

  24. baharezo macrumors newbie

    Oct 25, 2013
    try docomo when you're using your original sim data roaming cuz that's what bmobile actually uses.

    once you apply APN profile successfully you should lose all the services, then when you swap your sim you should regain 3G. as long as 3G appears on top you can open up browsers to check if you can have access to the internet.

    you should have no service on the provider side while using bmobile's sim cuz the visitor sim does not include any phone/SMS service.
  25. DarkShadowIB macrumors newbie

    Oct 26, 2013

Share This Page

27 September 19, 2013