After upgrading to iOS 5 the actual phone app keeps crashing

Discussion in 'iOS 5 and earlier' started by themiw, Oct 13, 2011.

  1. themiw macrumors newbie

    Oct 13, 2011
    Updated my iPhone 4 to iOS 5 yesterday. Everything seems to work fine, it seems, except the actual phone app.

    When I click it to make a call it immediately crashes and goes back to the home screen.

    I was able to make a call by calling out of the address book but the screen was blank. At the top I got the green bar saying "Touch to return to call" and when I clicked on it I'd see the regular phone stuff you'd expect to see for a split second before the screen went back to black with the green bar at the top.

    I was unable to end the call without turning the phone off.

    I can receive calls and everything works fine until I answer the call. I'm able to talk with no problems but I get the same problem described above when actually looking at the phone.

    I have tried turning the phone off and also hard resets but nothing works.

    Anybody know what's wrong or how to fix?


  2. saving107 macrumors 603


    Oct 14, 2007
    San Jose, Ca
    Have you deleted the from the multitask tray?
  3. themiw thread starter macrumors newbie

    Oct 13, 2011
    After clearing all apps out of the multitask tray it still didn't work but I then did a hard reset and it appears to work fine now.

    Thanks for the suggestion. I never would have thought of that on my own.
  4. ru4real macrumors member

    May 19, 2010
    I had the same problem - and when I went to look under Diagnostics & Usage it was showing crash reports multiple times per second for the Like you I restarted my phone and it seems to be working fine now. Not sure what else was going on, but my phone was also burning through the battery and the entire device was noticeably warm. It appears to be back to normal now.
  5. themiw thread starter macrumors newbie

    Oct 13, 2011
    It appears I spoke too soon.

    Just received a call and after it was done went to hang up and noticed the "return to call" green bar at the top.

    The caller hung up before I could touch it but just went back into phone app and it crashed again just like before.


    Also this thing is eating battery power like it's going out of style. Ever since this morning when I went into a building where I lose the 3G network and it goes to Edge. To get back to 3G after leaving this building I always have to turn the phone off and on.

    Lost 3 percentage points since I started typing my previous reply.
  6. falconv9 macrumors newbie

    Nov 28, 2011
    Did anyone have any luck with this issue? My phone app still crashes instantly after opening... I just upgraded to iOS 5 on an iPhone 4 as well.
  7. themiw thread starter macrumors newbie

    Oct 13, 2011
    what fixed it for me was wiping the phone and reinstalling it again. i can't remember if i started from scratch or from a back up.
  8. falconv9 macrumors newbie

    Nov 28, 2011
    themiw - thanks for the quick reply... I was hoping no one would say that >_< ... wiping / re-installing isn't a very pleasant process. Has anyone else resolved this without having to re-install?
  9. rdauster macrumors newbie

    Jul 17, 2012
    Re-install / Restore didn't work for me

    I've just been through a hellish 3-day restore process (my bakcups were corrupted?!)... it didn't work; the phone app continues to crash.

    I can't figure out what is the triggering event.

    While waiting for the ipHone 5, I'm now in the habit of dialling my home number every 30mins or so to see if the phone app is working. When not, I have to power down/up the phone.

Share This Page