Aftermarket battery not recognised

Discussion in 'macOS High Sierra (10.13)' started by TheGoog, Jun 21, 2017.

  1. TheGoog macrumors member

    Joined:
    Jul 11, 2008
    #1
    Just noticed that my wife's 2014 MBA 13" is not showing the battery status icon in the menu bar. When selecting the option in System Preferences, it disappears immediately. It also shows batter at 0% in System Preferences.

    In System Profiler, it shows no battery info at all.

    To check if it was an issue with the installation of the OS, I booted the High Sierra installer from USB, no battery icon shown, but the same USB on my MBP shows the battery icon.

    Tried with a Yosemite USB stick I had laying around, and the battery shows on both when booting from that.

    Only difference between the two are that the Air has an aftermarket battery, so obviously no support from Apple on this.

    Has anyone else seen this behaviour?
     
  2. Ultracyclist macrumors regular

    Ultracyclist

    Joined:
    Oct 13, 2014
    Location:
    Zwijndrecht, Netherlands
  3. Faraday macrumors member

    Joined:
    Mar 25, 2004
    Location:
    Melbourne Australia
    #3
    Just checked on my MBA Mid 2011. Aftermarket battery (Floureon), recently replaced.

    Battery is correctly seen in High Sierra DP2 release (build 17A29j). In Menu Bar, in system profiler, and in Coconut Battery.
     
  4. ebarbosaf macrumors newbie

    Joined:
    Jul 4, 2012
    #4
    Same exact issue on my wife's 2010 13" MacBook Pro. We have High Sierra Beta 2 Update 1 running on it.
     

Share This Page