Age of Empires 3 error

Discussion in 'Mac and PC Games' started by ConorMac, Jul 24, 2008.

  1. ConorMac macrumors newbie

    Joined:
    Jul 24, 2008
    #1
    I got Age of Empires fairly recently and it has been working fine the last couple days until this afternoon. The game's graphics started to go all funky and then, after a series of freezes, it "Quit Unexpectedly". Then I tried to reboot the game and play again, but it quit unexpectedly. By now I've tried at least 10 times to reboot the game, but each time it quits unexpectedly before it gets to the main menu. If anyone knows what's going on, or maybe even how to stop it from crashing, it would be greatly appreciated.
     
  2. Beric macrumors 68020

    Beric

    Joined:
    Jan 22, 2008
    Location:
    Bay Area
    #2
    If all else fails, I'd try a fresh reinstall.

    I haven't had the same problem as you, but when I had a CRC error, I just reinstalled the game and everything was fine.

    But what are your system specs? It almost sounds like it's happening because you don't have the graphics card capabilities or something.

    And do you have the latest update installed?
     

Share This Page