Age of Empires 3 (PC) on a mac

Discussion in 'Windows, Linux & Others on the Mac' started by brenm666, Jan 25, 2011.

  1. brenm666 macrumors regular

    Joined:
    May 30, 2010
    #1
    Hey everyone...
    I just found my old AoE3 game (the PC version, not the mac version) and I would like to know if I am going to have to install it on Parallels or its going to work on Mac.

    Thanks!
     
  2. callmemike20 macrumors 6502a

    callmemike20

    Joined:
    Aug 21, 2007
    Location:
    USA
    #2
    As with any program or game, you must have the version for your operating system. Mac won't be able to read that file without having windows installed. Plus, parallels won't be the best option because it doesn't work well with games. I would recommend installing windows in boot camp.
     
  3. DonCarlos macrumors regular

    DonCarlos

    Joined:
    Dec 14, 2009
    Location:
    Las Vegas
    #3
    What coincidence, I just came across all three of my Age of Empires. I can tell you that they work fine if you have Windows 7 installed via Bootcamp.
     
  4. loby macrumors 6502a

    loby

    Joined:
    Jul 1, 2010
    #4
    Try this www.codeweavers.com
    You can run the program without installing windows or fusion etc. This emulates the Windows environment on the OS X and Linux operating system without the fluff. The only issue is that the program only works with some of the PC programs... Check the compatibility listings to see what programs work. Make sure to get the 'Crossover Games' for gaming. I have not tried to install Age of Empires III, but it states that it will run the game....

    I love the Age of Empires series, but have not found anything that will run the Age of Empire's I Expansion without having to use boot camp.

    Any other suggestions from anyone?
     
  5. brenm666 thread starter macrumors regular

    Joined:
    May 30, 2010
    #5
    thanks everyone! finally i just decided to take the Mac version, its just easier. but ill take a look at your emulator loby.

    thanks again guys!

    edit: codeweavers would of worked well, like my old PoP game! :) i think i might give it a shot!
     

Share This Page