Age of Empires II gold ed Crashing

Discussion in 'Mac and PC Games' started by Sam726627, Sep 12, 2012.

  1. Sam726627, Sep 12, 2012
    Last edited: Sep 12, 2012

    Sam726627 macrumors newbie

    Joined:
    Sep 12, 2012
    #1
    Hello there, probably like most of you when I got a Mac I started to miss my old PC games. So I've recently been fining ways to play them (Wrappers etc) and today I got Age of Empires II Gold Edition, and it starts up perfectly fine. I can read the menus, watch the videos etc. But as soon as it begins to load a map or a game it crashes. I think I have sourced the problem down to myself not having the correct permissions to change the file or something.

    When I press CMD-I, I can't change the permissions to "read and write for everybody" I have even tried using the 'root' user to see if that has the privileges, but that does not either. I even tried ~/Library/Preferences/Age of Empires II Preferences but it tells me I don't have permission? Any help would be greatly appreciated :)
    Running Mac OS X 10.6.8 3.06 GHz Intel Core 2 Duo

    I have a bit of code telling you all abit about the problem more in-depth
     
  2. stuckwithme247 macrumors regular

    Joined:
    Jan 14, 2003
    #2
    It would help a lot if we knew what these so-called "wrappers" you are referring to are.

    What I can tell you is that I recently played AOE2 on Windows 7 64-bit and it ran fine. I had to play around with compatibility mode a little bit if I recall, but eventually it worked. Your best bet is going to be to install Windows 7 using Boot Camp, or possibly Parallels and run it there.

    After playing a little AOE2 I decided to get AOE 3 Complete which is great also in my opinion.

    Good luck
     
  3. Sam726627 thread starter macrumors newbie

    Joined:
    Sep 12, 2012
    #3
    Oh sorry, lack of clarification on my part. I'm not using any wrappers to run AOE2 this time. Because the game already comes in a Mac version. But if it makes any difference I normally use Wineskin for other titles.

    I always held out from parallels but I guess I'll finally give it a shot. Mailed apple too and they can't give me a response to change locked permissions.
     
  4. stuckwithme247 macrumors regular

    Joined:
    Jan 14, 2003
    #4
    Mac OS X 10.6.8 can't run classic mode. This means you are pretty much out of luck as far as support goes. It may be possible to emulate Mac OS 9 and run the game there, but you can't run the game natively on OS X. Hope this info helps.
     
  5. shulerg macrumors regular

    Joined:
    Nov 18, 2009
  6. goMac macrumors 603

    Joined:
    Apr 15, 2004
    #6
    Whaaaaa? Age of Empires 2 is Mac OS X native. I used to play it on Mac OS X all the time.

    It doesn't have an Intel binary, but that's another can of worms...
     
  7. Northwestern macrumors regular

    Joined:
    Sep 13, 2011
    #7
    They should bring it up on the MAS, best AOE of all time imo.
     
  8. gregorsamsa macrumors 6502a

    Joined:
    Apr 6, 2006
    Location:
    (Metamorphosing near) Staffs, 51st State.
    #8

Share This Page