AGP videocard compatability

Discussion in 'Mac Basics and Help' started by SheerGold, Jul 3, 2007.

  1. SheerGold macrumors member

    Joined:
    Apr 20, 2006
    #1
    I have a G5 dual 1.8 and am having problems with the AGP videocard.

    Can I replace it with "any" AGP card from "any" Mac?

    Or do I need to check that the replacement card is fully compatible?
     
  2. MacsRgr8 macrumors 604

    MacsRgr8

    Joined:
    Sep 8, 2002
    Location:
    The Netherlands
    #2
    You need an AGP 8x Mac-card.... and, those are only found in G5's.

    Try to get a good card like this ATi Radeon 9800 SE

    Maybe if you could find a GeForce 6800 Ultra, that would be even better.
     
  3. SheerGold thread starter macrumors member

    Joined:
    Apr 20, 2006
    #3
    Thanks for the guidance.

    Do you know what would happen if I put the AGP card from the last model of G4 (1.25 dual) into my G5?

    It looks as if the G4 has a 4x AGP card.
    Would that work in my G5 and simply force the AGP slot to work at 4x without any problems?
     
  4. MacsRgr8 macrumors 604

    MacsRgr8

    Joined:
    Sep 8, 2002
    Location:
    The Netherlands
    #4
    IIRC an AGP 4x card simply won't fit in the G5.

    There were reports on getting a modded AGP 8x card in a G4, but an AGP 4x card in a G5.... don't think so. :(
     

Share This Page