AHCI v 1.3 on Classic Mac Pro Possible?

Discussion in 'Mac Pro' started by stmp, Sep 15, 2014.

  1. stmp macrumors member

    Joined:
    Jul 17, 2012
    #1
    Hi there,

    Anyone know if it's possible to force an AHCI driver update to 1.3 on classic Mac Pro towers?

    From my understanding AHCI is updated to 1.3 on OS X on all newer iMacs/Mac Mini/Macbook Pro/nMP but somehow being prevented on cMP.

    Any input advice here would be great. Hope is to take advantage of the built in port multiplication support in AHCI 1.3.

    Thanks in advance!
     
  2. 666sheep macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
    #2
    It's supported on cMP but not on ICH. Only with newer controllers.
    Marvell 88SE92xx (Sonnet, Highpoint, Addonics SATA 6Gb/s PCIe adapters) seem to support 1.20 only as well.
    See screenshots: first is Samsung NGFF on Lycom DT-120, second is mSATA on Lycom PE-125.
     

    Attached Files:

  3. stmp thread starter macrumors member

    Joined:
    Jul 17, 2012
    #3

    Attached Files:

  4. 666sheep macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
    #4
    After a some more research, it seems the answer isn't that straightforward as it appears... Need to study drivers dependencies a bit.

    If you want to use port multiplier feature, you can try Sonnett driver. I can't say if it's restricted to their cards only, but maybe it's worth a try: http://www.sonnettech.com/support/downloads/software/dskcd-ahci_pm-11.dmg
    Back your original AppleAHCIPort.kext before installing, or install it on a spare drive just in case.
     
  5. crjackson2134 macrumors 68020

    crjackson2134

    Joined:
    Mar 6, 2013
    Location:
    Charlotte, NC
    #5
    Just to add a bit more information, the Velocity Solo X2 only supports 1.19 with Yosemite PB3. I'll check and see what Mavericks uses in a little while.
     

Share This Page