iPad Air 2 nagging me to activate a cellular account

Discussion in 'iPad' started by Rigby, Oct 25, 2014.

  1. Rigby macrumors 601

    Joined:
    Aug 5, 2008
    Location:
    San Jose, CA
    #1
    Does anybody else get occasional "reminders" to activate a cellular account on the Air 2? I currently have no need for cellular data (I usually buy a limited-time pass while I'm traveling only), so this is slightly annoying. I also noticed that the option to turn off cellular isn't there anymore in the settings. :confused:
     
  2. scaredpoet macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #2
    Really? Under "Cellular" In settings, I can turn cellular data off. It's the first option there. Then the carrier name just reverts to "iPad."
     

    Attached Files:

  3. Rayban macrumors 6502

    Rayban

    Joined:
    Sep 5, 2008
    #3
    Yep I get the same reminder dialog. Only option under Cellular Data is "Set Up Cellular Data"
    I'll be setting it up soon though but it gets annoying. Completely random.
     
  4. Rigby thread starter macrumors 601

    Joined:
    Aug 5, 2008
    Location:
    San Jose, CA
    #4
    Same here. I'm attaching screenshots of the cellular settings and the nag dialog box which just popped up again.

    Scaredpoet, did you activate a carrier?
    EDIT: Just saw in your screenshot that you did. So that seems to be the only way to get the "off" switch.

    .
     

    Attached Files:

  5. Night Spring macrumors G5

    Night Spring

    Joined:
    Jul 17, 2008
    #5
    I have the off switch in settings, and I haven't activated a carrier. I did, however, tap "set up carriers data" and browse through the various carrier options.
     
  6. Rigby thread starter macrumors 601

    Joined:
    Aug 5, 2008
    Location:
    San Jose, CA
    #6
    Weird. I browsed the carrier options too, didn't help. I also just tried popping in one of my other SIMs. With that SIM inserted, the full cellular options appear. But after switching back to the Apple SIM, they are gone again and the nag is back. Annoying.
     
  7. Night Spring macrumors G5

    Night Spring

    Joined:
    Jul 17, 2008
    #7
    Hmmm. I just went back to my carrier settings, and there is no off switch! But I haven't gotten any nags. But I've also been connected to wifi the whole time I've been using my Air2.
     
  8. scaredpoet macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #8
    I would just go ahead and set up a T-Mobile 200MB free plan and leave it at that. You won't be required to set up a payment method, and you'll get a free 200MB of data per month, if you want it. And if not, you'll get the option to turn off Cellular data and never deal with it.

    When you do travel, you can just reactivate the Apple SIM with the carrier of your choice, as T-Mobile doesn't lock down your SIM.
     
  9. Rigby thread starter macrumors 601

    Joined:
    Aug 5, 2008
    Location:
    San Jose, CA
    #9
    Yes, I just activated the free T-Mobile plan.

    However, I'm wondering what happens if I activate a different carrier on the Apple SIM. Will that deactivate the T-Mobile plan (which could potentially mean losing the free 200MB if they decide to terminate that offer)? From the "Data Plan" page in the settings it almost looks like you can have multiple plans active at once and switch back and forth between them, as long as none of them locks down the SIM like AT&T does ...

    Guess I'll get a backup Apple SIM before my next trip just in case.
     

Share This Page