Air Cooling an old 2.7 G5

Discussion in 'PowerPC Macs' started by MacProFan4, May 28, 2017.

  1. MacProFan4 macrumors newbie

    Joined:
    Mar 3, 2017
    Location:
    New Jersey
    #1
    Hi there to folks tuned in to PPC interests! Recently, I was lucky to have purchased for a very small amount,several G5s. Amoungst them were a pair of Dual Processor 2 GHz units, and one historically interesting (at least to me) 2.7 GHz unit. I had sorted the units out first by the processor speed and number info as on the sticker inside the side door. A 2.3 Ghz unit, Dual Processor, had on it's sticker "PMG5/ DP2.3/ PCI etc..", and the 2.7 GHz unit had on it's sticker "PMG5 2.7 GHz/512MB/ etc..". Which was puzzling, for I thought the 2.7 GHz speed only came as a dual processor unit, not a single. I also seemed to recall these units being the infamous Liquid Cooled horrors. Not much later, when I got to examine them in more detail, I opened this one up, and saw, not to my delight, the Delphi Liquid Cooler mackiller. That which you could see of the cooler assy was remarkably clean, but from previous experience dissassembling a totally rotted out 2.5, the coolant evils lurked further below. I also noted the presence of two heatexchangers which confirmed that it was indeed a dual. Well, I got it cheap, so if it was gone, it was gone. I powered it up, and to my surprise, it was able to boot up. My interest was climbing. I pulled out the cooling unit and saw that the processor board bottoms (the sides facing the motherboard) were in great shape with no sign of corrosion. More optimism! Continuing, separating the processor boards from the cooler assembly, I found both boards to somehow escaped the rot from the leaky cooler assy, and were, basically, with no corrosion! This puppy was a keeper! Examining the cooler assy's bottom, it was apparent the unit had just started to leak, but the coolant hadn't gotten to the boards yet. Well, almost. I found a couple crumbs ( bits of "white rice") on the boards I was able to just brush off. Now I wanted to find a suitable set of Air cooled dissipators to convert this unit. One of the the 2 Ghz units had the appropriate copper based types, and thats whats on there now. Unit is working, but the fans (not unexpectedly) ramp up at the slightest processor activity. Which I don't remember them doing when the Liq cooling assy was on. One factor could be the motherboard may have monitored the coolant's pump current draw to verify the pump's working, and now with no pump, it may be getting alarmed seeing no current draw. In any event, I want to run the Apple Hardware Test (AHT) program that is on, if web research has it right, the application disk that would have come with this computer many moons ago. But I don't know it's right number. A fellow on this site, user "reddragOn" had run the same test to get his converted to Air cooled 2.5GHz unit to run right, and used a disk, "AHT disk 2.5.8". I don't know if the 2.5.8 title came from 2.5GHz version 8, or what. If someone knows what disk I should be running to get this 2.7's thermal control running right, I would appreciate it. Also along with that, whatever Apple's scheme was for numbering these disks would be nice to know for other units as well as this one. Thanks folks!
     
  2. redheeler macrumors 603

    redheeler

    Joined:
    Oct 17, 2014
    #2
    You can download ASD 2.5.8 from the Internet Archive here.

    That being said, the dual-processor 2.7 GHz is one of the hottest-running Power Mac G5 systems ever made and runs hotter than a 2.5 GHz. The fans will likely still be ramping up quite a bit in the absence of a liquid-cooler with not much you can do about it.

    In addition, I recommend you use a utility to monitor the CPU temperature (such as iStat Menus) and make sure it's not running too hot under load.
     
  3. MacProFan4 thread starter macrumors newbie

    Joined:
    Mar 3, 2017
    Location:
    New Jersey
    #3
    It's been an interesting two days. I've done a fair amount with PCs, but AppleLand is new territory. For those who like results short and sweet, here they are :
    > ASD (Apple Service Diagnostic) disk image was successfully downloaded from the location given in redheeler's response of 5/28 just above. Many thanks to redheeler for that link. That saved ALOT of web searching!
    > Download was done on a Mac to avoid any translational snags.
    > Two files were downloaded from that site. One, the ASD program itself in a compressed Disk Image format, or ".dmg" file compressed in a .zip format, and another file, a pdf file, that tells you about the program, how to use it, and, most excellantly, what Macs the program works with.
    > I saved the ASD program, opened the "how to" pdf file and printed it out.
    > I copied the ASD .dmg program into the left hand pane of Disk Utility, and burned a CD of it using that same program, Disk Utility.
    > Using the instructions in the pdf document, I was able to successfully run the OF and OS versions (or 'parts' may be a better term) of the .dmg from the CD.
    > The first test I ran was the hardware test, and the unit passed.
    > Next ran the Thermal Calibration test, and the unit failed on two tests, and the test ended.
    > I found the cause of those reported failures, eliminated those, and reran the Thermal Cal test.
    > This time, test reported only one failure, "CPU1's Tafs out of Range, replace processor 1".
    > Since by the program "Temperature Monitor" I had searched for, found, downloaded and installed previously, the two CPU's are tracking each other fairly closely, I'm not going to do any processor replacement. I'm content with the unit as it is, at least for the time being.
    > The foregoing was the nice, glossy, tidy account of this endeavor. I'm going to add after this posting the grittier account wth all the wrong turns and problems encountered en route to the finish line for all you folks who like details, and some juicy details I left out of the above. I split this up partially because I don't know how long winded an account I can enter before some software character counter says I've entered too many letters. Happy Computing
    --- Post Merged, May 31, 2017 ---
    The nitty grittier Account. This adds details left out of the above.
    > The download. The link was perfect, it took me to exactly what I was after. The .dmg file was exactly what was needed, the how-to pdf was a bonus. The .dmg file, was, however, compressed in a .zip file. Both files I downloaded. Once the .dmg.zip file got to the mac Download location, however, the .zip extension had disappeared, and the file size had changed from 206.3MB to 219MB. Not knowing whether or not the mac I was using was showing extensions, I hunted about and found under "Finder Preferences", "Advanced", an option to check (the currently unchecked) "Show all filename extensions" box. Ahh! the solution! I chked the box, and returned to the screen to redisplay my just downloaded .dmg.zip file. Still No .zip extension on the .dmg. Why NOT? Restart computer to have change take effect? Worth a try. Nope, that didn't do it. Seems like mac did the unzipping on the fly as it downloaded the file, as unlikely as that seems. But, well, the size HAD increased... but by just 2-ish MB? That's not much compression. With the ASD file selected, the file drop down menu did offer to compress the file, and so with that option in bold, that is available, that seemed to cement the DMG file as decompressed. Incidently, I was using a MacbookPro running Mavericks to do all this. So now I had a file I'm not sure to burn or just run (that's my inexperience) and I'm not sure if any burning program here will be able to process a zipped up file format if indeed it IS still zipped. I proceeded under the assumption the dmg file somehow got unzipped, even though I never told the computer to do that.
    Moving along, I had noted in my poking about that under in the file drop down menu is a "Burn" option. So I selected the ASD 2.5.8.dmg file, and used said burn option. CD burning seemed to go flawlessly with no announcements of operator stupidity or anything else amiss. When it was done, I removed the CD, and examined it to see if it had indeed been written to. It showed about one third to one half had been written to. Following the instructions on the pdf sheet, I tried to run the program off the CD. No luck, wouldn't run....Back to the 'net. One fellow there said you couldn't just do what I was doing, you had to use the "Disk Copy" program under Applications> Utilities>, put the ASD file in the left pane, and then go to "Image" menu, and select "open", then select opened asd file, then choose "Burn", none of which corresponded with what I was seeing/finding on my MBP, so apparently he was using a different OS version. However, the idea of using the Disk Utility on the MBP seemed a good thing to try, for a disk processing program might be smarter about converting a disc image file into a disc image on a disc than the other burn program. So, after I returned to the net to find out what key(s) to use on a mac to copy a file instead of just move the file as my MBP was insisting on, I copied the DMG file to the left pane of the Disk Utility. At the top, before you select (highlight) the file, our DMG file, the choices are : "Verify Info Burn Mount Eject ..." and others. When you select the dmg file, the "info" option becomes available, and the "Mount" option changes to "Open". So, I tried the "Open" option. It then gave me an activity bar, telling me it was attaching the .dmg file. When the activity stopped shortly thereafter, it told me that it was not possible to attach asd 2.5.8.dmg (no mountable file systems), whatever that means. Well, it meant that was a dead end, so forget that. No big deal, exited that submenu, lets go for the gusto: I hit Burn. And away it went. After it was done, I looked at the CD. This time, almost all the CD had been burned to. This seemed to be progress! Turns out it was progress.
    > The test. Again following the instructions on the pdf sheet, we started up the computer with the "C" button depressed, and we finally got satisfaction! A big blue screen with Apple Service Disk square in middle that changed into the Hardware test. So, I ran it. G5 passed. This was good. Now, I wanted to get to the Thermal Calibrate test, the objective all this effort was for. I choose that, and off it went. Came up with two significant sounding problems. One was:
    "ERROR CPU0 - CPU intake fan speed error. Check that inner door is secure and in place then rerun calibration."
    The other message was identical, except that it referred to CPU1.
    What the "Intake" fan was seemed pretty obvious, and after a few moments of thought, the "Inner Door" seemed to refer to the clear plastic air deflector just inside the side panel. There was no problem with the air deflector, and the fans spun fine. However, their tacks could have a bad connection, so I shut down, and pulled off and reseated the fan assy. Retested, same result. Replaced fan assy with another off another working G5. Same result. HHmmm. Fans are fine. Whats the G5 complaining about? Well, it's "missing" the pump of the Liquid Cooling Unit (LCU), and that pump had four wires. Two for the motor, and I'll bet the other two were for a tach. The cable for the LCU's pump was actually quite long, so I placed the complete LCU (in a plastic basin) on top of the present G5 under test, and ran the pump's motor leads to it's connector using available holes so I could keep the air deflector fully snuggled up against the G5's frame. Ran test again. Excellent! This time, no mention of any Fan fault. The software is wrong about what is wrong. It confuses the coolant pump speed sensor with the pair of intake fan speed sensors! Now with the software confused about how fast the pump that's not there is running, or confused about the intake fans that are running, one would expect the software to be nervous about how it's cooling system is protecting it's processors. Put another way and more to the point, the thermal software may be more hasty about ramping up the fans than whats neccessary. As I pointed out in the previous post, the Temperature Monitor program says the processors are OK. So, for the moment, I'm leaving the system as is, but may do two things in the near future. One, remove CPU1 assy and smooth the surface of the base of the cooler plate that contacts the processor tops. It's no mirror surface like the processor tops themselves. The other is concoct a circuit to present to the motherboard the same load the pump presented, and using that same power to create a speed signal to fake the motherboard into thinking theres a pump there running along just fine. But thats later.. Happy tinkering everyone!
    --- Post Merged, May 31, 2017 ---
    PS : Forgot to mention : The ASD program, on it's last run DID produce an announcement of a thermal failure. It was "CPU1 Tafs out of range, replace processor." Not Comforting, I REALLY want to know just what "Tafs" represents. But again, for the moment due to Temperature Monitor's report of things being OK at the processors, I'm not sweating the Tafs thing.... But what DOES it MEAN???
     

Share This Page