Air won't join networks at startup anymore

Discussion in 'MacBook Air' started by abecker, Sep 25, 2011.

  1. abecker macrumors member

    Feb 27, 2008
    I noticed within the last couple of hours that my 2011 13" air won't join wireless networks automatically at start anymore.

    If I click the AirPort icon and select the network it joins instantly.

    Here's what I've tried:

    1) Rebooting the computer.
    2) Removing the networks from network preferences.
    3) Removing the entries from the keychain
    4) Restarting the router.
    5) Resetting the router to defaults and redoing the configuration.

    Any ideas? I have an airport extreme router.

    I know it's not the end of the world; but it's kind of annoying. Especially since it's worked for over a month.
  2. aziatiklover macrumors 68030


    Jul 12, 2011
    Location: and
    Go under system preference in network, and delete all the network you have connected to. Then add the one you need restart you should be good.
  3. abecker thread starter macrumors member

    Feb 27, 2008
    That was the 2nd thing I tried.
  4. aziatiklover, Sep 25, 2011
    Last edited: Sep 25, 2011

    aziatiklover macrumors 68030


    Jul 12, 2011
    Location: and
    oops sorry didn't see that. Kinda weird you having that issue after deleting all that. Have you switched router or done any updates to your MBA or router?
  5. wpotere Guest

    Oct 7, 2010
    My guess is that you are running Lion. Buggy network connections with Lion. Hopefully a patch will fix this soon.
  6. abecker thread starter macrumors member

    Feb 27, 2008
    No changes to either in the last week or so.
  7. KPOM macrumors G5

    Oct 23, 2010
    I'm guessing it is Lion. The 10.7.2 update is coming soon and hopefully will fix it. Consider yourself lucky that you went a month before the issue cropped up. I noticed it right away with my Time Capsule and 2011 MacBook Air. It's been good for the past 2 weeks, though.

    Are you noticing it after anything in particular? For me, when it went into deep sleep it was more likely to lose the network connection than when it was in normal sleep.
  8. aziatiklover macrumors 68030


    Jul 12, 2011
    Location: and
    Thats kinda suck. Cuz i had the same issue when upgraded to Lion with my 2010 11" and all i did was just deleted all networks that i have connected to.
  9. hfg macrumors 68040


    Dec 1, 2006
    Cedar Rapids, IA. USA
    I see you already deleted all your network history. However, for others, instead of deleting all of your wireless network history, you might try moving your preferred network to the top of the list and then retrying you connection.

    Of course, this would also be a good time to clean up the list by deleting any old hotel, coffee shop, airport, etc. connections that you aren't likely to ever visit again in the near future.;)

  10. Chipg macrumors regular

    Aug 17, 2010
    Mine just started doing this yesterday after over a month with no problems, I have an i7 13 air with lion and have done all the updates.

    No changes in my router or drivers/software for it.
  11. iRabbit macrumors 6502

    Jul 10, 2007
    Mine wont connect at all.... It's telling me invalid password even though I'm 100% certain it's correct. I'm connected to the same network now with my iPad.

    Very annoying! Have no idea how to fix it.
  12. skyton macrumors 6502

    Jan 3, 2005
  13. pollaxe macrumors 6502


    Aug 13, 2010
    West of England
    I was having similar problems and something that seemed to help me was clearing out the network keychains, restarting the MBA and entering the network details anew.

    It's not perfect but wifi has been a lot better for me since I did this. Having read around on the matter however, different fixes seem to help different people but have no effect on the problem for others!

Share This Page