Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

airdrop between rMB and iOS 9 not working

objektør

macrumors regular
Original poster
Nov 25, 2014
248
18
At home
My gf just got an iPad mini 4 (iOS 9.3). She also has an MBA (El cap 10.11.3). To move files between them I used airdrop. Very smooth and easy.

I tried the same thing with my rMB (EL cap 10.11.4) but the mini is not recognized. Same thing other way around. The mini does not detect my rMB.

Anyone else having this issue with their rMB? Or better: solution to this problem?

FWIW: I have also this issue with my HDD and usb-C flash not detected by the rMB every now and then.
Both work flawlessly on her MBA.
 

rrm998

macrumors regular
Jun 15, 2012
198
4
Houston, TX USA
I was trying to airdrop between my 2016 rMB and an iPhone 6s Plus just today. Neither device was visible to the other in the airdrop window. This is the first time I've tried Airdrop in a while so I don't know what the root cause is. I've never found airdrop between iOS and Mac to be totally stable but the usual tricks of reseting wifi and rebooting the devices didn't help. I'm running the most current versions on both devices.
 
Comment

jeremiah256

macrumors 65816
Aug 2, 2008
1,283
985
Southern California
Two days ago, also had issues trying to use AirDrop between my iPhone 6S Plus and a 2012 MacBook Air. It ended up working, but I had to turn both devices' radios on and off several times. And both are up-to-date.
 
Comment

objektør

macrumors regular
Original poster
Nov 25, 2014
248
18
At home
thanks for the replies.
So it is not just the rMB having this issue.
Read in some other thread that it could help to turn of firewall. Didn't work for me.
And iCloud should be activated on both devices. It was on ours even though my rMB was on my own account and not on the mini.
I might try later on the same account even though I think that this would make airdrop less useful.
 
Comment

applesith

macrumors 68030
Jun 11, 2007
2,666
1,144
Manhattan
Air Drop never worked for me. I tried a few times on my rMB and iPhone 6S. Also recall trying back on iPhone 6 to iPad Mini 2.
 
Comment

Rhonindk

Contributor
Iphone 6S+, rMB, iPad Mini 4.
As of this morning my rMB can see my iPhone and Airdrop doesn't work.
As of this morning my rMB cannot see my iPad Mini.
As of this morning my iPhone cannot see either my rMB nor my iPad Mini.
As of this morning my iPad Mini can see everyone and Airdrop does not work.
As of this morning Airdrop is totally borked.

Last week ... it worked between my iPhone and my rMB.

Color me confused and I currently do not rely on Airdrop. I do try it off and on to see if something has changed and it has suddenly started working.
 
  • Like
Reactions: jeremiah256
Comment

Abazigal

Contributor
Jul 18, 2011
13,452
11,831
Singapore
Airdrop has always been very unreliable when working between iOS devices and Macs. Between my iPhone and iPad, no issues.
 
Comment

walala

macrumors member
Sep 6, 2007
32
5
Same problem.

My experience with AirDrop below. I had a 2008 MBP that I just retired and it didn't have AirDrop until I recently got the 2016 12" MacBook so I've now had a chance to test AirDrop on OS X.

1) iPhone 5S to iPhone 5S - worked consistently for years, no issues.
2) iPhone 6S Plus to iPhone 6S Plus - works consistently, no issues.
3) 2016 MacBook to iPhone 6S Plus - almost never works. I've tried literally at least 100 times, trying every troubleshooting method online...i.e. disabling WiFi/Bluetooth on both devices, etc. It has worked exactly ONCE completely randomly and I still have no idea how it actually worked that one time.

Fairly disappointing that it is a great feature that essentially does not work at all.
 
Comment

Mildredop

macrumors 68020
Oct 14, 2013
2,438
1,496
Air Drop between Macbook and Macbook Pro wouldn't work for me.

Air Drop is utter crap. It seems Apple did a half-arsed job haven't bothered to sort it out.
 
Comment

walala

macrumors member
Sep 6, 2007
32
5
Same problem.

My experience with AirDrop below. I had a 2008 MBP that I just retired and it didn't have AirDrop until I recently got the 2016 12" MacBook so I've now had a chance to test AirDrop on OS X.

1) iPhone 5S to iPhone 5S - worked consistently for years, no issues.
2) iPhone 6S Plus to iPhone 6S Plus - works consistently, no issues.
3) 2016 MacBook to iPhone 6S Plus - almost never works. I've tried literally at least 100 times, trying every troubleshooting method online...i.e. disabling WiFi/Bluetooth on both devices, etc. It has worked exactly ONCE completely randomly and I still have no idea how it actually worked that one time.

Fairly disappointing that it is a great feature that essentially does not work at all.

OK, and just like that, it is now working, minutes after posting the above. I wasn't even trying to use AirDrop.

I was trying to share an iOS iMovie file to email or some other app. AirDrop popped up on the share screen and...my MacBook showed up. Transferred the iMovie file (tried Project and File, both worked). Then transferred another, it worked. Then tried a photo from iOS Photo app, worked fine.

The only thing I can think that has changed is:

1) Installed OS X 10.11.5 on May 31st
2) I've been travelling and I'm on a different WiFi network which is extremely fast (does this even matter? it's using direct phone to computer connection, right?)

No idea if this will continue working, but seeing it work at least a few times is really nice actually.
 
Comment

Rhonindk

Contributor
OK, and just like that, it is now working, minutes after posting the above. I wasn't even trying to use AirDrop.

I was trying to share an iOS iMovie file to email or some other app. AirDrop popped up on the share screen and...my MacBook showed up. Transferred the iMovie file (tried Project and File, both worked). Then transferred another, it worked. Then tried a photo from iOS Photo app, worked fine.

The only thing I can think that has changed is:

1) Installed OS X 10.11.5 on May 31st
2) I've been travelling and I'm on a different WiFi network which is extremely fast (does this even matter? it's using direct phone to computer connection, right?)

No idea if this will continue working, but seeing it work at least a few times is really nice actually.

I don't think wifi speed is an issue. I am on a 200 down / 20 up wifi network.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.