AirDrop Dead Horse

Discussion in 'iPhone' started by Shikaka, Oct 25, 2016.

  1. Shikaka macrumors regular

    Joined:
    Sep 12, 2014
    #1
    I used to scoff at everyone who complained about AirDrop. It always worked perfectly for me on my 6 Plus and 6S Plus.

    I just picked up a 7 Plus and now I can't get the darn AirDrop to work! My wife's 6S Plus has no problems AirDropping photos to me, but when I try to send anything to her, I don't even see her as an available contact.

    I updated to 10.1, toggled airplane mode, Bluetooth and WiFi. Even tried a hard reset with no luck. Any other ideas?
     
  2. Mlrollin91 macrumors G4

    Mlrollin91

    Joined:
    Nov 20, 2008
    Location:
    Ventura County
    #2
    Reset network settings? Might trigger something. Yes you have to re-enter all your WiFi passwords, but might be whats needed..
     
  3. BeeGood macrumors 68000

    BeeGood

    Joined:
    Sep 15, 2013
    Location:
    Lot 23E. Somewhere in Georgia.
    #3
    Like @Mlrollin91 said, resetting network settings works sometimes. For me, Sometimes it seems to fix itself.

    This has been a recurring problem for me and my wife since AirDrop came out. I think it has happened with each iPhone we've had from the 5s to the 7+.

    Sorry this is happening to you, but glad to see you're a believe now :D
     
  4. ivanwi11iams Contributor

    ivanwi11iams

    Joined:
    Nov 30, 2014
    Location:
    Atlanta, GA
    #4
    For me, my missus iPhone has to have the screen on, in order to Air Drop (not sure if this is a requirement, or) to her phone...
     
  5. JT2002TJ macrumors 6502a

    Joined:
    Nov 7, 2013
    #5
    It is, it has to not only be on, it has to be unlocked...
     
  6. Shikaka thread starter macrumors regular

    Joined:
    Sep 12, 2014
    #6
    Yes, I tried a network reset and both phones were unlocked.
     
  7. Bryan Bowler macrumors 68040

    Joined:
    Sep 27, 2008
    #7
    Under Steve Jobs, things "just worked". Nowadays, there are tons and tons of things that don't work.

    For years now, AirDrop has been incredibly inconsistent and I'd estimate that it only works about 40-50% of the time.
     

Share This Page