AirDrop over ethernet?

Discussion in 'macOS High Sierra (10.13)' started by HiFiGuy528, Nov 13, 2017.

  1. HiFiGuy528 macrumors 68000

    Jul 24, 2008
  2. cruisin macrumors 6502a


    Apr 1, 2014
    The command is for enabling the legacy AirDrop mode, and therefore it won't work with iOS devices (as far as I know).

    You could just turn on WiFi for the moment you need to AirDrop, if WiFi staying on is an issue. I imagine you can even script it to turn on for 5 minutes and then turn off. iOS 11 pretends to turn off Bluetooth and WiFi so that AirDrop still works.

    I don't think there is a non-WiFi option as AirDrop is peer-to-peer by design and so it works without routers.
  3. Czo macrumors 6502

    Dec 30, 2008
    Debrecen, Hungary
    Why u would like to turn off WiFi? Disabling IPv4 and IPv6 is not what you want? I’m using it with disabled v4 and v6 on my iMac, and everything is working
  4. tromboneaholic Suspended


    Jun 9, 2004
    Clearwater, FL
    Agree with question and solution. Seems like the baby is being thrown out with the bath water by OP.
  5. Anonymous Freak macrumors 603

    Anonymous Freak

    Dec 12, 2002
    This is the answer. The "interoperable" version of AirDrop specifically uses WiFi Direct. It doesn't just use "network". You have to have WiFi turned on to use AirDrop. It's also one of the reasons only newer Macs support it - because the WiFi chipset in older Macs doesn't support WiFi Direct.
  6. HiFiGuy528 thread starter macrumors 68000

    Jul 24, 2008
    I try keep WiFi turned off on as many devices as possible because I already have 12 different devices on the wireless network. Just thought to keep the network at minimum congestion if I can was wired instead on the iMac. Looks like I should just manually turn on wifi when using Airdrop.
  7. torpidlittle macrumors newbie

    Oct 24, 2014
    --- Post Merged, Mar 15, 2018 ---
    Hi All,

    I know this is a bit old tread but I'd like to add some details about Czo comments:

    As Czo said, you can just use the Wi-Fi locally only (no internet).
    • In the main page, "Disconnect" from you current network (using "Network Name: dropdown list").
    • Uncheck the "Automatically join this network".
    • Go to "Advanced...", under "TCP/IP" section, do the following:

    Screen Shot 2018-03-15 at 10.36.41 PM.png

    • Click "OK" and "Apply".

    Your Wi-Fi should now be turned "On" but not connected to internet anymore (a yellow light should show beside Wi-Fi).

    And Airdrop should now work as expected.

    Hope this helps!

Share This Page

6 November 13, 2017