Airmail - Exchange issue

Discussion in 'Mac Apps and Mac App Store' started by Jaypi, Nov 10, 2013.

  1. Jaypi, Nov 10, 2013
    Last edited: Nov 10, 2013

    Jaypi macrumors regular

    Jaypi

    Joined:
    Nov 10, 2012
    Location:
    Los Angeles
    #1
    Hey guys,

    I recently installed Airmail and I think it's one of the best E-Mails app for Mac out there ... Too bad that I have issues with my Exchange account.

    I put in all information (domain, username, password & the http:// address), but I get a error message when ever I check the settings. Is there any trick? It's working in Outlook for Mac and in Apple Mail, just not for Airmail.

    Some more information:
    Domain field: I put in the same information as on my iPhone
    HTTP: I got the information from Outlook since the auto discover works there

    The error message is in the attachment.

    The most weird thing is that I received a couple mails (maybe 20), but not the rest. The Airmail folders got created as well.

    It would be awesome if somebody can help me out here.

    Thanks !
    JP
     

    Attached Files:

  2. captaindigital macrumors newbie

    Joined:
    Jan 24, 2012
    Location:
    Earth.
    #2
    I'm having the exact same problem!

    I've just installed AirMail. Same deal with Exchange server - nothing I do with the configuration works, and I get the same dialog in response.

    I really want to switch to AirMail - the default Mac client is too buggy (and doesn't support Gmail in any way I've found to be usable). But I have to have Exchange support for work!

    Brad
     
  3. jlc1978 macrumors 68000

    jlc1978

    Joined:
    Aug 14, 2009
    #3
    It appears Exchange doesn't work in Airmail. I've got it to work with Office and Mail but Airmail is a no-go. Would be nice if they fixed that.
     
  4. microdev macrumors newbie

    Joined:
    Jun 28, 2007
    #4
    Airmail Exchange 1.3.1 Solution (worked for me)

    I tried damn near every combination I could devise to get the autodiscover to work. My web URL (using the OWA path) is connect.mycompany.com and that didn't work. So I tried a full path to the autodiscover URL itself using https://autodiscover.mycompany.com/.../exchange.asmx, which is the MS recommended path when autodiscover fails. However, that also did not work.

    In Apple Mail advanced settings you see the full Endpoint path under Internal Server Path. In my case it is EWS/Exchange.asmx. Using the full path seemed to fix the problem and I was able to connect to my exchange account:

    https://autodiscover.mycompany.com/EWS/Exchange.asmx

    Hope that helps someone.
     
  5. weaseldrum macrumors newbie

    Joined:
    Jul 22, 2011
    #5
    Follow this

    You, sir, are a genius!
     
  6. BadCircuit, Jan 10, 2014
    Last edited: Jan 10, 2014

    BadCircuit macrumors newbie

    Joined:
    Jan 10, 2014
    #6
    The above helped thanks, i had to play around a bit but this is what I did:

    I have been following the advice on this link to get the EWS endpoint URL, but it did not work for me.
    "http://blogs.msdn.com/b/deva/archive/2013/05/09/10243481.aspx"

    Lets say that URL was
    https://abc.mycompany.services.co.za/EWS/Echange.asmx

    We also have a OWA Outlook Web Access address that looks like:
    https://webmail.company.co.za/owa

    I then tried to combine these to and ended up with:
    https://webmail.company.co.za/EWS/Echange.asmx

    This URL seemed to do the trick and connect to exchange.
     
  7. dwest73 macrumors newbie

    Joined:
    Mar 15, 2011
    Location:
    Sweden
    #7
    Thank you everyone, this has been driving med mad! :D
     

Share This Page