Airplay asking for passcode?

Discussion in 'Apple TV and Home Theater' started by hcanning, Oct 6, 2016.

  1. hcanning macrumors newbie

    Joined:
    Jun 26, 2014
    #1
    Recently my Apple TV 4 has started asking for a passcode when I airplay from my iPhone 6.

    Obviously this is all disabled in the menus. I've tried rebooting both devices.

    Any ideas?
     
  2. cynics macrumors G4

    Joined:
    Jan 8, 2012
    #2
    Any possibility you are accidentally trying to long onto someone else AppleTV?
     
  3. hcanning thread starter macrumors newbie

    Joined:
    Jun 26, 2014
    #3
    No.
     
  4. cynics macrumors G4

    Joined:
    Jan 8, 2012
    #4
    Do you have a different device to try AirPlaying with aside your iPhone 6?

    If not I guess I would just restore the ATV to see if that fixes it.
     
  5. WassHammoud macrumors newbie

    Joined:
    May 2, 2011
    #5
    Bump...I'm having the same issue on my Apple TV. I thought software updates would eventually fix it. It seems to work for a bit, but after turning the setting off it always comes back and asks for a password to use AirPlay.
     
  6. rockyromero macrumors 6502

    rockyromero

    Joined:
    Jul 11, 2015
    #6
    So, enter the password.

     
  7. Flat Six macrumors newbie

    Joined:
    Jul 14, 2012
    #7
    I had the same problem. What I did was set it on 'ask password' and use it for a bit. Then I set it on 'no password' and then it worked as it should be. Just confirm 'don't ask password' (it was on that setting) over and over again didn't work. So I tried a different setting, used it, and then went back to the setting 'don't ask password'.
     
  8. mendodave macrumors newbie

    Joined:
    Jul 21, 2015
    #8
    ok, fixed it.
    definitely a bug
    this worked for me, sending from imac to appletv4 latest os
    unpair any idevices from apple tv
    connect with itunes Mac, enter code pops up
    look at TV, code is there
    enter code, iTunes works
    re-enter paired devices
    code pops up on TV now.
    before it would not, with iPhone 6s+ paired
     
  9. davidoloan macrumors 6502

    Joined:
    Apr 28, 2009
    #9
    This has appeared on my apple TV4 for the first time since it came out. I don't have the option to turn it off. The least restrictive option is that it will ask for it first time it sees an airplay device.

    I just entered the code, but I'm not sure I see the reason for this. Surely a code should only be required if a visitor is using the bluetooth airplay method, not wifi, which prevents people trying to airplay to the next door neighbours TV.
     
  10. jjschereriv macrumors newbie

    jjschereriv

    Joined:
    Oct 22, 2017
    #10
    --- Post Merged, Oct 22, 2017 ---
    Where the heck do I FIND the code?! It's been working for a month and suddenly started asking me for the code. But a friend installed it for me so I'm clueless. . .
     
  11. davidoloan macrumors 6502

    Joined:
    Apr 28, 2009
    #11
    It should appear on your IOS device without you having to look for it, just on the screen.

    Mine stopped it after a short while and works correctly again. I don't know why you are getting the bug at a different time; I thought it was fixed.
     
  12. cynics macrumors G4

    Joined:
    Jan 8, 2012
    #12
    What are your devices being used? iPhone, Mac? And which AppleTV? ATV3, 4, 4K?

    Under normal circumstances the device you are using iPhone, iPad, Mac etc will ask for a passcode. Meanwhile on the TV from the AppleTV a passcode should be displayed. Enter that and it should work.

    However there can sometimes be some hiccups. I find very good reliability with AirPlaying iOS devices to AppleTV's however not so much with Macs. Currently I can't even get my iMac to AirPlay mirror (just sound works, and iTunes videos work).
     
  13. marklemac macrumors regular

    marklemac

    Joined:
    Oct 21, 2003
    Location:
    Southampton, UK.
    #13
    This was annoying me so I spent a bit of time on it and sussed it out (no more asking for airplay passwords)

    On the ATV do this:

    Settings
    Airplay
    Airplay
    Security
    Use Password
    click done

    It will now show as 'require password > NEVER' ;)

    job done :)
     
  14. priitv8 macrumors 68020

    Joined:
    Jan 13, 2011
    Location:
    Estonia
    #14
    BTW this NEVER option returned with tvOS 11. It was not an option in tvOS 10. Best bet on 10 is - Ask once.
     
  15. davidoloan macrumors 6502

    Joined:
    Apr 28, 2009
    #15

    That didn't work when I had the bug. It just stopped as quickly as it started.
     
  16. marklemac macrumors regular

    marklemac

    Joined:
    Oct 21, 2003
    Location:
    Southampton, UK.
    #16
    That's a shame, mines been sweet as a nut since doing this.
     

Share This Page