AirPlay Audio from iPad's iPod App Not Working with Apple TV 2

Discussion in 'Apple TV and Home Theater' started by movethefloor, Nov 24, 2010.

  1. movethefloor macrumors newbie

    Joined:
    Feb 12, 2007
    #1
    I've been running the 4.2 betas on my iPad for a few months, and updated to the GM 4.2.1 on Monday. Audio AirPlay worked fine (while video obviously didn't) up until the last beta. At that point, whenever I'd send audio to Apple TV, Apple TV wouldn't recognize it nor would it play any audio, while the iPad chugged along happily streaming the audio (track progressed, AirPlay icon was blue). I checked volume, tried changing tracks, rebooting and all that. I was hoping the problem would be fixed with this final release but it's not. Has anyone else experienced this problem?

    Edit: my Apple TV software is up to date as well.
     
  2. GOverbey macrumors newbie

    Joined:
    Nov 25, 2010
    #2
    Same problem

    I have the exact same problem no audio but I can see the videos with no audio. It's very annoying I have updated my apple tv and itouch and have also tried with iPad does anyone know what to do?
     
  3. movethefloor thread starter macrumors newbie

    Joined:
    Feb 12, 2007
    #3
    Also, I've noticed that I'm unable to send audio from the iPhone's iPod app at all -- there is no AirPlay icon. I'm going to guess that they didn't have time to work the kinks out with AirPlay and we'll see updates with 4.3 or whenever they implement additional functionality. That being said, if someone does find a way to fix this, do tell!
     
  4. MyJelleo macrumors 6502

    Joined:
    Mar 29, 2007
    #4
    My airplay button was missing too from the ipod app until I rebooted the phone. After the reboot, the button appeared...however, the audio streaming is very buggy for me.

    I'll start the airplay for the music, but the appletv doesn't play anything. Then everything else starts to get wonky -- movies won't stream, apple remote won't connect. Once I reboot, everything is fine until I try streaming music again. I'm glad I'm not the only having this issue. I searched all over google and found that a lot of people are having no issues with audio...so I'm wondering what's going on...
     
  5. macfan1970 macrumors newbie

    macfan1970

    Joined:
    Oct 19, 2010
    Location:
    Poland
    #5
    Two days ago upgraded iPhone 4 to 4.2.1. ATV is 3.0.2, same network and no airshare icon on iPhone!!!???
    Is it possible only the 2nd ATV generation works fine?
    Thanks
     
  6. KeithJenner macrumors 6502a

    Joined:
    Sep 30, 2010
    #6
    Yes, it's just ATV2
     
  7. macfan1970 macrumors newbie

    macfan1970

    Joined:
    Oct 19, 2010
    Location:
    Poland
  8. MyJelleo macrumors 6502

    Joined:
    Mar 29, 2007
    #8
    Seriously, no one else is having this issue with the ATV and streaming audio?
     
  9. ptaylor9 macrumors member

    Joined:
    Sep 16, 2009
    #9
    Airplay only works with the latest ATV2 with latest version of the ATV2 iOS.
    The old apple TV isnt being updated to include this functionality, its running an old operating system, and Apple hve said they wont be updating it any more.
     
  10. GOverbey macrumors newbie

    Joined:
    Nov 25, 2010
    #10
    ???

    I can't find anyone other then this page having trouble with 2nd generation apple tv updated and an updated iPad. The audio just won't play there has to be something going on
     
  11. macfan1970 macrumors newbie

    macfan1970

    Joined:
    Oct 19, 2010
    Location:
    Poland
  12. MyJelleo macrumors 6502

    Joined:
    Mar 29, 2007
    #12
    What kind of router are you using? I'm assuming its my router.
     
  13. GOverbey macrumors newbie

    Joined:
    Nov 25, 2010
    #13
    Problem solved

    I figured out what to do I just unplugged my apple tv and plugged it back in and it was fixed. Don't know how but that did the trick
     
  14. MyJelleo macrumors 6502

    Joined:
    Mar 29, 2007
    #14
    I've tried that too. It didn't work for me. I'm able to use airplay to stream music from my macbook pro to the atv. It appears to be really buggy because when I did it that way, the apple tv actually crashed once. After rebooting the thing, it was fine...

    My iphone and iPad still have issues though.
     
  15. Wxyz1234 macrumors newbie

    Joined:
    Jun 23, 2010
    #15
    Same issue here.
    Streaming audio from the iPad won't work. Can't stream it to the ATV2 (latest software) and my Airport Express doesn't even show up as a device for streaming from the iPad. I have tried from the ipod application and from Pandora. Same issue.

    If I do try to stream audio from iPad to ATV2, it freezes the wifi on my iPad, and only rebooting the iPad will get it working again.

    Streaming video from iPad works fine (with sound)

    Streaming audio and video both from iPhone 3GS works fine too.

    So it seems to be an iPad audio streaming issue...
     
  16. tonyburkhart macrumors regular

    tonyburkhart

    Joined:
    Jan 24, 2010
    Location:
    Ohio
    #16
    Works on one iPad, but not the other...

    Well, I am confounded...

    My wife's 16GB WiFi only iPad sees my Ver 6.3 Airport Express in her ipod app and can choose to stream music to it, which operates successfully every time.

    My AT&T 3G iPad, has never seen or shown the Airport Express/AirTunes options, ever.

    We are both on 4.2.1 (8C148)

    For troubleshooting I have power cycled my iPad and tried turning off cellular connectivity, so I am on WiFi only. I don't want to do a restore, but in my mind, that's the "on deck" troubleshooting technique, after deleting/forgetting the WiFi network and recreating the connection.

    I am going to try deleting/reconnecting and report back in a few.

    Any and all suggestions are welcome, as I am stumped on this one!
     
  17. newagemac macrumors 68020

    Joined:
    Mar 31, 2010
    #17
    Are you sure your iPad is on the same network as your wife's iPad? Check both IP addresses and make sure all the numbers before the last dot are exactly the same.
     
  18. sk8ah121 macrumors newbie

    Joined:
    Nov 21, 2010
    #18
    I'm running one of the last betas of 4.21 on my iPad and I can stream audio fine to my ATV2. I can even stream the audio track to a video file to the ATV2, but the video signal stays with the ATV2 menu and shows the icon and track name like I am playing a song...

    I'm trying to update my iPad to the latest OS release but it is telling me that my software is up to date. Any tips on how to get the latest rev of 4.21 on the iPad?
     
  19. iMat77 macrumors member

    iMat77

    Joined:
    Feb 5, 2008
    Location:
    Ticino, Switzerland
    #19
    Buggy airplay

    Same problem here. All iOS are up to date. Streaming YouTube videos was working like charm, whereas iPod app (in iPad) wouldn't stream any audio. Rebooted apple tv (menu down + menu button pressed until light flashes faster and then released to restart device). Now it works as advertised. So I guess the problem is in the ATV not in the iPad.

    Hope it helps some of you solve it. Let's see how long it lasts... I hope I'm good now, for a while. Love airplay, because the ATV doesn't have any hdd and I can leave my MBP in the office from time to time..
     

Share This Page