Airplay icon appears but can't connect.

Discussion in 'Apple TV and Home Theater' started by FixMyMacbook, Feb 2, 2014.

  1. FixMyMacbook, Feb 2, 2014
    Last edited: Feb 2, 2014

    FixMyMacbook macrumors newbie

    Joined:
    Feb 2, 2014
    #1
    Setup:
    Apple TV 3
    Macbook Pro 13" (Mid 2013)
    OS X Mountain Lion 10.8.5
    Netgear DGN2200 router

    So my problem is that i cannot connect my macbook pro to my apple tv. I see the airplay icon and can see my apple tv under the menu. When i press connect, the icon turns blue and the resolution changes. The beach ball comes up for about 10 seconds and then the connection is lost. It's weird because my apple tv can see my macbook pro's itunes library name, but can't open it. It just shows "Loading library name" for a while and then fails.

    I have a windows 7 pc and that works perfectly with streaming media from itunes to the apple tv. So it's not a problem with the network. My itunes in windows can also see the name of my macbooks itunes library, but fails to connect to it.

    I've tried all the obvious solutions ie resetting the apple tv, restarting macbook, disconnecting the itunes library, resetting the router. Nothing has worked.

    If anyone has any information that could help I would appreciate it!
     
  2. 2010mini macrumors 68040

    Joined:
    Jun 19, 2013
    #2
    Check to see if your router's firmware is up to date. Airplay uses protocols and if your router is not up to date, might cause issues.
     
  3. FixMyMacbook thread starter macrumors newbie

    Joined:
    Feb 2, 2014
    #3
    Checked that. And updated ATV. No change.
    Any other suggestions?
     
  4. paulrbeers macrumors 68040

    Joined:
    Dec 17, 2009
    #4
    Are both your Macbook and AppleTV on the same subnet? You aren't creating a separate wifi vs ethernet network are you?
     
  5. waw74 macrumors 68030

    Joined:
    May 27, 2008
    #5
    google your routers model number and "airplay"

    look for a setting called WMM, and toggle that, it might help, it might not.
     
  6. Fixmyairplay macrumors newbie

    Joined:
    Jul 16, 2014

Share This Page