Airplay mirroring doesn't work since Mavericks.

Discussion in 'Apple TV and Home Theater' started by esbx, Oct 26, 2013.

  1. esbx macrumors newbie

    Joined:
    Oct 26, 2013
    #1
    Hey
    I've been experiencing an issue with my 3rd generation Apple tv since i installed Mavericks on my early 2011 MBP.

    When trying to enable the Apple TV as a secondary display, it tells me:
    Could not connect to "Apple tv"

    I can however use an App to get video onto the big screen with no problems.
    So just to make it clear, it is the full display mirroring that's acting up, and not the Apple tv in general.

    This is what i have done to try to fix it:
    Update Apple tv
    Restart it, then forget WiFi and reconnect.
    Restart Mbp, forget Wifi and reconnect.

    Could this possibly be related to Mavericks new "way" of handling things with multiple displays?
    Does anyone know how to fix this?
     
  2. waw74 macrumors 68030

    Joined:
    May 27, 2008
  3. esbx thread starter macrumors newbie

    Joined:
    Oct 26, 2013
    #3
    Yes i restarted the router
     
  4. Mikeyde1989 macrumors newbie

    Mikeyde1989

    Joined:
    Jun 16, 2013
    Location:
    Melbourne, Australia
    #4
    I was having issues with my MBA 2013 freezing when I hit connect to Apple TV before and after mavericks. Was told at the apple store to do exactly what you did; update the mac & Apple TV software first and then if still persistent reset the settings in the MacBook Air. I also had to reset my modem and then I was finally able to turn on home sharing & continue airplay mirroring.

    However I was told by the genius if this didn't fix it to also restore my Apple TV. Though you'll need a cable to hook it up to your mac.

    Goodluck. This can be so ***** annoying.
     
  5. esbx thread starter macrumors newbie

    Joined:
    Oct 26, 2013
    #5
    Hmm okay. I'll try to reset the Apple tv and try again.
    Thanks :)
     
  6. Mike MA macrumors 65816

    Mike MA

    Joined:
    Sep 21, 2012
    #6
    I somehow have a different problem: Since installing Mavericks connecting iTunes to my 3rd gen Apple TV for streaming music takes about 5-10 seconds. Under ML it used to be somewhat of a second.

    Additionally the initial connection built most of the time is not providing any music - I have to switch to a second song/album that I actually hear something.
     
  7. mikehallad macrumors newbie

    Joined:
    Dec 17, 2013
    #7
    Turn off firewall

    Had the same issue with 2012 Mac air AFTER Mavericks update. No Apple TV at all. Tried resetting ATV, updated , unplugged, network connections identical etc.

    Finally read about turning off my firewall in Security and Privacy on Mac. THAT WORKED.

    Now to Apple, what did you change from Lion to Mavericks to cause this firewall issue????

    PS If I turn off my firewall, run airplay from my MBAir, and then turn firewall back on airplay continues to work fine.
     

Share This Page