• Did you order new AirTags? We've opened a dedicated AirTags forum.

kat.hayes

macrumors 65816
Original poster
Oct 10, 2011
1,216
26
I have a new Macbook Air on the same network as my AppleTV, however, there is no Airplay Mirroring option at the top. I do have the checkbox enabled in preferences under displays. How do I get it to display?

Thanks.
 

xylitol

macrumors 6502
Nov 2, 2013
312
65
Finland
Is your AppleTV 2nd gen or later, and is its software updated? Have you also checked its settings? Have you tried rebooting it and router?
 
Comment

kat.hayes

macrumors 65816
Original poster
Oct 10, 2011
1,216
26
It is the 2nd gen ATV and I have mirror my iPhone and iPad to it before and my older Mac using Air Parrot.

I will check to see if there is an update.

Is Home Sharing something I do on the Mac, or just on the AppleTV?


Thanks.
 
Comment

kat.hayes

macrumors 65816
Original poster
Oct 10, 2011
1,216
26
I downloaded the most recent update to the ATV, and turned on and off the mirroring option in preferences and it still does not work....
 
Comment

dean1012

macrumors regular
Jul 10, 2008
130
0
Just a note, home sharing is *not* required to do Airplay.

If your other devices can connect it doesn't sound like a network or ATV issue. More than likely something misconfigured or messed up on the mac. is the Mac firewall turned on?
 
Comment

Jambalaya

macrumors 6502a
Jun 21, 2013
693
106
UK
You are definitely running Mavericks ? Sorry to ask such a dumb question. We have no problem with mirroring from MBP but the mac mini is too old so no mirroring options appears.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.