AirPlay not showing when Apple TV is sleeping

Discussion in 'Apple TV and Home Theater' started by A4orce84, Sep 30, 2014.

  1. A4orce84 macrumors 6502

    Joined:
    Apr 17, 2012
    #1
    Hello Everyone,

    I just got my Apple TV, and I thought the Airplay icon showed up on my MacBook and my other devices when the Apple TV was sleeping, and selecting it would wake the Apple TV up.
    However, when the Apple TV goes to sleep recently, the icon disappears. Is there an option I need to activate in order to restore my Apple TV's behavior back when I could wake it up with Airplay?

    Thanks!

    Apple TV (3rd generation)
     
  2. orestes1984 macrumors 65816

    Joined:
    Jun 10, 2005
    Location:
    Australia
    #2
    No, it should just sit there in your Airplay options.
     
  3. A4orce84 thread starter macrumors 6502

    Joined:
    Apr 17, 2012
    #3
    I'm not sure I quite understand you orestes1984. Are you saying this is the normal behavior?

    Can you clarify please? Thanks.
     
  4. naquellaq macrumors newbie

    Joined:
    Jan 31, 2014
    #4
    Airplay Icon in Menubar

    A4orce84,

    Having recently run CAT6 into a room with an AppleTV I decided to connect it to a switch I'd run for devices there to be hard wired to the LAN. I noticed it turning up missing in the menu bar. For me, going to the AppleTV's remote to wake it up did the trick but of course it just disappears again after the device goes into sleep mode. This got old very quickly so I decided to try disconnecting the ethernet cable and re-enabling the wireless connection between the AppleTV and the LAN. It seems to continue to stay in the menubar now. Writing this just reminded me how I was trying to figure out why I couldn't Airplay audio from my iPad to it... now it makes sense... It's there in the pull up menu in iOS 8 like it should. Good-Luck
     
  5. A4orce84 thread starter macrumors 6502

    Joined:
    Apr 17, 2012
    #5
    So basically switching to wifi fixed your problem? I also have a hard connection via the ethernet cable currently.

    I thought there was a feature to "wake" up the AppleTV with Airplay? Is that not the case?
     
  6. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #6
    The latest version of the Apple TV software apparently has a bug where Ethernet-connected Apple TVs do not show up when sleeping. Switching to Wi-Fi is the workaround until Apple gets this fixed. See also:

    http://forums.macrumors.com/showthread.php?t=1788098

    A.
     
  7. A4orce84 thread starter macrumors 6502

    Joined:
    Apr 17, 2012
    #7
    Has Apple admitted that this is a bug? Is there an official Apple document / release with any information around this?

    Thanks,
    Asif
     
  8. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #8
    No statements that I am aware of.

    A.
     
  9. orestes1984 macrumors 65816

    Joined:
    Jun 10, 2005
    Location:
    Australia
    #9
    I'm not quite sure you can comprehend me, the simple answer is NO it's not normal behaviour.
     
  10. naquellaq macrumors newbie

    Joined:
    Jan 31, 2014
    #10
    AppleTV; Airplay; lost functionality

    Yes, pretty much so... with one caveat, on my iPad and iPhone when I attempt to airplay audio I've had to try seeing if it's "showing up" when I flick up the screen... it's not showing up as soon as it used to. It took a couple to three tries before it decided to appear, apparently the time it's taking the AppleTV to wake on LAN. Hey, at least I have the ability to use it again.
     
  11. jezzastern macrumors newbie

    Joined:
    Mar 28, 2008
    #11
    I have an aTV 3 connected by Ethernet with the latest firmware applied. I have no problems seeing Airplay when the aTV is in sleep mode, and waking the unit up via AirPlay. Try restarting your aTV and see if that helps. Maybe it is a router problem. Mine is an AirPort Extreme.
     
  12. Nozuka macrumors 68000

    Joined:
    Jul 3, 2012
    #12

    there are 2 versions of the atv3. do you have the 2012 (A1427) or 2013 (A1469) model?
    they are almost identical, but the newest version supports peer-to-peer airplay now - which might have broken other things.

    i got the 2013 model and got the standby bug since the update.
     
  13. cyber16 macrumors 6502

    Joined:
    Jan 12, 2013
    #13
    the 2012 (A1427) model has the same bug. As I posted last weekend, enabling wifi first then using ethernet is a temp fix
     
  14. A4orce84 thread starter macrumors 6502

    Joined:
    Apr 17, 2012
    #15
    macrumors regular

    Join Date: Apr 2012

    Hello Everyone,

    Thanks for all the comments and updates. I'm glad I'm not the only one experiencing this issue with an Ethernet connection.

    For the time being, I have set the sleep timer to "never" and will continue to operate this way until Apple pushes out an update to address the issue. I rather use the speed of the ethernet than wifi, since my wifi connection isn't the greatest, and I can image a lot of lag when trying to use Airplay over wifi because of it.

    Hope Apple pushes out something soon! =(

    Thanks,
    Asif
     
  15. houser macrumors newbie

    Joined:
    Oct 29, 2006
    #16
    It worked for me too so it's a fix really and not just a temp one.
    It seems to be set so it works as intended after doing this.
    Thanx!
     
  16. Speninem macrumors newbie

    Joined:
    Oct 19, 2014
    #17
    Hi. As noted above adding wireless network then switching back to Ethernet worked for me too, so seems to be a reliable fix until Apple correct in future update.

    Thanks to all for posting this fix.
     
  17. VideoBeagle, Oct 19, 2014
    Last edited: Oct 19, 2014

    VideoBeagle macrumors 6502a

    Joined:
    Aug 17, 2010
    Location:
    App Q&A testing by request.
    #18
    How do you see this info? Mine says FD199LL/A when I look in the About Screen

    In the meantime, I submitted bug report: 18704017 for this.
     
  18. twintin macrumors 6502

    Joined:
    Aug 10, 2012
    Location:
    Sweden
    #19
    it's printed on the label at the bottom (can be hard to see due to the small printing).
     
  19. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #20
    The latest Apple TV update causes my (Wi-Fi) Apple TV to disappear when it goes to sleep. I have not tried connecting it to Ethernet to see if that bug has been fixed at the cost of breaking wireless.

    A.
     
  20. sodapop1 Suspended

    sodapop1

    Joined:
    Sep 7, 2014
    #21
    I did a lot of software updates yesterday including iOS 8.1, ATV 7.1, Yosemite and iTunes 12. Initially, I saw a lot of weird stuff from Air Play not showing up when my ATV went to sleep from my entire movie collection not being visible to ATV.

    Eventually, I got all of those issues to go away by trying various things from restarting devices, restarting iTunes and reconnecting each device to ATV.
     
  21. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #22
    I followed my own advice ( http://forums.macrumors.com/showpost.php?p=20134336&postcount=2 ) and powered everything off while I was out and about. Everything was fine when I powered it all back up.

    I think Apple TVs, Airports, and OS X all keep track of a lot of dynamic stuff, and the only way to make then forget is for them *all* to forget. :)

    A.
     
  22. Cherish, Oct 25, 2014
    Last edited: Oct 28, 2014

    Cherish macrumors member

    Joined:
    Sep 27, 2014
    #23
    Restarting everything will only work for some time then it stops working again on Ethernet connection.

    EDIT: Wifi has the same problem too. It worked well for 5 days but it just suddenly stopped appearing again on sleep.

    https://www.apple.com/feedback/appletv.html - Submit feedback to Apple so they will fix it asap!
     
  23. MiamiC70 macrumors regular

    Joined:
    Oct 16, 2011
  24. peixesloucos macrumors member

    peixesloucos

    Joined:
    Dec 1, 2012
    Location:
    Brussels
    #25
    My Apple TV (3rd gen with the latest update) is connected wireless to my network (cable modem + airport express). Now I can not find Apple TV when its sleeping on my airplay. So is the bug also valid in the WIFI connected Apple TV?

    I have done a company reset recently because of the lag problem and this issue come up. Before I did not have any problem.
     

Share This Page