AirPlay not streaming video

CosmoPilot

macrumors 65816
Original poster
Nov 8, 2010
1,422
84
South Carolina
Wirelessly posted

Music and audio works, but no video. Antone else have this issue? iOS and AppleTV updated to latest software.
 

waw74

macrumors 68040
May 27, 2008
3,157
189
what are you trying to send the video from?

some apps dont allow you to send video.
 

CosmoPilot

macrumors 65816
Original poster
Nov 8, 2010
1,422
84
South Carolina
Wirelessly posted

Bump.

My MBP streams video just fine to the AppleTV. I'm having the issue with streaming video from my iPhone5. Anyone else? Trying to determine if this is a widespread problem or something on my end.
 
Last edited:

lunaoso

macrumors 65816
Sep 22, 2012
1,331
50
Boston, MA
Wirelessly posted

Bump.

My MBP streams video just fine to the AppleTV. I'm having the issue with streaming video from my iPhone5. Anyone else? Trying to determine if this is a widespread problem or something on my end.
Well, I can tell you that the new YouTube app (the one Google put in the app store upon the iOS 6 launch) doesn't work with Airplay right now. I've been having to use it on the actual Apple TV, which, is inconvenient, hopefully Google will update that soon.

For the video app though, what is the problem? What are you doing (step by step)? Have you tried it on any other iOS device to the same Apple TV? Are you sure you are Airplaying and not AirPlay Mirroring? Can you AirPlay from any other app, such as an embedded video within Safari?
 
Last edited:

CosmoPilot

macrumors 65816
Original poster
Nov 8, 2010
1,422
84
South Carolina
I play a video using the iOS Apple provided "video" app.

I play video, video plays fine.
I then pres the AirPlay icon (square with triangle tip inside it). I then select "Living Room Apple TV".

Audio plays fine from the video; however, the video does not stream to the TV. I've used this feature in the past without issue, so I'm thinking this is a bug of some kind.
 

lunaoso

macrumors 65816
Sep 22, 2012
1,331
50
Boston, MA
The YouTube app (video) does work with AirPlay. Some apps require mirroring to be turned on.
I find that kind of pointless though because
1. It only fills part of the screen
2. It drains more battery
3. The people in my house without an airplay mirroring device can't use it.

Google needs to fix that ASAP.

----------

I play a video using the iOS Apple provided "video" app.

I play video, video plays fine.
I then pres the AirPlay icon (square with triangle tip inside it). I then select "Living Room Apple TV".

Audio plays fine from the video; however, the video does not stream to the TV. I've used this feature in the past without issue, so I'm thinking this is a bug of some kind.
Hmm... Did you try turning the iDevice off and then back on? Or holding the home and lock buttons together for 10 seconds until it restarts(some call it a hard reset others a soft reset)?
 

CosmoPilot

macrumors 65816
Original poster
Nov 8, 2010
1,422
84
South Carolina
Hmm... Did you try turning the iDevice off and then back on? Or holding the home and lock buttons together for 10 seconds until it restarts(some call it a hard reset others a soft reset)?
Yeah, I've done those things. Pictures from the photo app show up on the AppleTV, just no video.

I'm assuming you're not having any troubles since you're helping me troubleshoot. I was hopeful others would chime in with whether or not they are experiencing the same issue or not.
 

lunaoso

macrumors 65816
Sep 22, 2012
1,331
50
Boston, MA
Are you up-to-date on all software?
Yeah I'm having no problems... I do have a 4S and not a 5, but I'm still tryin to help either way ;). I'm thinking the videos you are trying to play are protected (prob. DRM). Because if I try to airplay some things the audio will only play because of the protection. Are the videos from iTunes?
 

CosmoPilot

macrumors 65816
Original poster
Nov 8, 2010
1,422
84
South Carolina
Yeah I'm having no problems... I do have a 4S and not a 5, but I'm still tryin to help either way ;). I'm thinking the videos you are trying to play are protected (prob. DRM). Because if I try to airplay some things the audio will only play because of the protection. Are the videos from iTunes?
Yep, the only videos I have are from iTunes. Again, this worked for me in the past. It's very strange! The audio plays through the AppleTV just fine, but the video won't. Pictures from the photo app show up just fine. I can't even get mirroring to work (games, etc.)!
 

lunaoso

macrumors 65816
Sep 22, 2012
1,331
50
Boston, MA
Yep, the only videos I have are from iTunes. Again, this worked for me in the past. It's very strange! The audio plays through the AppleTV just fine, but the video won't. Pictures from the photo app show up just fine. I can't even get mirroring to work (games, etc.)!
So it's probably not copyright protection then if mirroring doesn't work either... Has it ever worked on your 5?
 

CosmoPilot

macrumors 65816
Original poster
Nov 8, 2010
1,422
84
South Carolina
Have you tried airplaying them from any other iOS device?
I googled the issue, apparently this is a widespread issue. I sent Apple a bug report. Hopefully it will get fixed. I appreciate your help on the matter, but Airplay is such a simple feature. It's definitely a bug of some kind. Seems most are having the issue with iPhone5 and iPad2s.
 

lunaoso

macrumors 65816
Sep 22, 2012
1,331
50
Boston, MA
I googled the issue, apparently this is a widespread issue. I sent Apple a bug report. Hopefully it will get fixed. I appreciate your help on the matter, but Airplay is such a simple feature. It's definitely a bug of some kind. Seems most are having the issue with iPhone5 and iPad2s.
Glad you found at least a reason for the problem. Hopefully for your sake it gets resolved soon. :)
 

stevcb

macrumors newbie
Mar 13, 2017
5
0
Victoria BC Canada
I googled the issue, apparently this is a widespread issue. I sent Apple a bug report. Hopefully it will get fixed. I appreciate your help on the matter, but Airplay is such a simple feature. It's definitely a bug of some kind. Seems most are having the issue with iPhone5 and iPad2s.
I have and Iphone 5s also and the exact same issue is my problem as well. Got sound and no video. Even if I try and play a video from the video app from Apple, and use a video I shot with my phone. No joy in Victoria BC Canada. I also have and ipad 2 and it does not work as well. Come on apple please fix this bug or whatever you did to my system.
 

ROBB D

macrumors newbie
Apr 26, 2017
1
0
Wirelessly posted

Music and audio works, but no video. Antone else have this issue? iOS and AppleTV updated to latest software.

Has there been a discovered fix to this other than restoring the MAC. This is a macOS issue. I don't recall exactly how long ago this happened to me, but I had to reset my Mac. resetting the Apple TV was not a fix. this issue needs fixed. it has been many months, but it has happened again.

all software is updated! my iPhone, and iPad stream video flawlessly in airplay. the Mac won't. I'm resetting my Mac this weekend. I shouldn't need to fix this issue this complexly. apple needs to invest some time into this one.