Airplay seeing (2) next to name?

cynics

macrumors G4
Jan 8, 2012
11,624
1,904
No idea but mine has started doing that too. Not all the time, just randomly.
 

oneMadRssn

macrumors 603
Sep 8, 2011
5,246
12,209
Europe
My guess is that Apple keeps a table somewhere of all registered devices on a network. When the Airplay device loses its connection, for whatever reason, it is not purged from this table fast enough, and there is a conflict when it reconnects with the same name.

Since the Airplay service is an interesting dual server and client service on all the devices without a centralized server (each device acts as a server at first waiting for connections from a client, then when a connection is established they switch roles and the device becomes a client and the earlier client becomes a server), I am not sure how Apple keeps this table up to date on all the devices.

However they do it, it's obviously not purging prior instances of a connection quick enough and causing the conflicts you are seeing. Most likely each device keeps its own table, but once there is a single conflict on any device causing the renaming, the renaming is propagated to all other devices.

Again, this is just a guess based on my prior experiments (years ago) trying to reverse-engineer Airplay.
 

Imac Sam

macrumors 6502
Oct 9, 2011
309
17
Harrisonburg, Virginia
I am having this issue happen on my Imac running 10.9.5 as well. I can leave the computer off, change the Apple TV device name to something totally different. As soon as I check it using Airplay on the Ipad it shows as "name(2)". It is interesting to note that I did replace this unit from an Atv-2 to an Atv-3 a few months back, and it is always shows the "(2)" on the replacement unit, but not on an totally different Atv-2 elsewhere in the house.
 

quackers82

macrumors 6502
Original poster
Mar 13, 2014
340
168
Found that i can get rid of it by opening up the Airplay name setting and pressing submit without actually changing anything. Still a pain when you have 30+ Apple TVs to do it too.
 

LewisChapman

macrumors 6502a
Jan 10, 2015
600
860
I found that adding a space to the end of the Apple TV name solved the issue for me on several Apple TV's located around the house.
 

frankdogg

macrumors 6502
Mar 24, 2011
307
138
Mid-Wilshire LA
i have this issue because i re-setted all of my settings on the ATV but ended up reusing the same name. Maybe that's what you are experiencing as well?
 

cynics

macrumors G4
Jan 8, 2012
11,624
1,904
i have this issue because i re-setted all of my settings on the ATV but ended up reusing the same name. Maybe that's what you are experiencing as well?

That isn't the case for me. It wasn't until Yosemite update or an AppleTV update that I started noticing it.

The issue seems to come and go as its pleases or at least I haven't noticed the common denominator. It does not effect performance.
 

tate16t

macrumors newbie
Dec 28, 2014
28
0
Found that i can get rid of it by opening up the Airplay name setting and pressing submit without actually changing anything. Still a pain when you have 30+ Apple TVs to do it too.
This worked for me. The 2 is no longer appearing.
 

thekb

macrumors 6502a
May 8, 2010
629
23
I'm up to AppleTV (179). The number just keeps growing, but I've ignored it.

"Found that i can get rid of it by opening up the Airplay name setting and pressing submit without actually changing anything."

Is this done on the AppleTV device, or on your mac?
 

cynics

macrumors G4
Jan 8, 2012
11,624
1,904
Anyone figure this out yet? I've tried resubmitting the same name and changing the name. A (2) is still there when I bring up AirPlay menus in iOS and OSX.

Sometimes it won't be there. Other times it will change mid way through AirPlaying and it disconnects (that's how I notice the name change).

I currently have an active question open for every Apple device in my sig minus the AirPort. What is going on with them anymore? Feels so half assed. Wish they would stop adding features and streamline the ones they already have.
 

That-Guy

macrumors 6502a
Feb 25, 2012
652
56
UK
Just started getting this, it seems to be since the last Apple TV update for me.

Tried changing Apple TV Name, reseting Airport Express.

It seems to fix it for a few days then starts again, I only have the one Apple TV in the house too.
 

LewisChapman

macrumors 6502a
Jan 10, 2015
600
860
I have found a solution which is (so far) proving true..

1. Change name of Apple TV to something random temporarily.
2. Go to network settings and change setup of DHCP config to static.
3. Restart Apple TV
4. Change name to the name you wanted originally.
5. Restart Apple TV

From what I've read, this bug exists due to the way that the Apple TV sleeps. When the Apple TV wakes from sleep it temporarily exists as a ghost of itself because it wakes as a new identity. The router sees the Apple TV as a second device and bonjour issues the '(2)' you see after the name. The original identity seems to be stuck somewhere (this part I'm not sure on) and thats why at times you see the correct name and at other times you see the '(2)'.

I could be completely wrong here, it's just what I think is happening.
 

sentiblue

macrumors regular
Aug 2, 2012
199
99
Silicon Valley
I have an ATV in each room at home. The one in the living room has Airplay enabled. This issue is annoying me so much. The name with the random (#) doesn't just show up on AirPlay... it also shows up in the remote app on my phone... my wife keeps asking why that number keeps changing and I can't really give her an answer.
 

cast128

macrumors regular
Jul 24, 2003
143
85
Colorado
I have an ATV in each room at home. The one in the living room has Airplay enabled. This issue is annoying me so much. The name with the random (#) doesn't just show up on AirPlay... it also shows up in the remote app on my phone... my wife keeps asking why that number keeps changing and I can't really give her an answer.
I’ve been having the same problem over the past week or so. It isn’t such a big deal, but it’s driving the perfectionist in me nuts!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.