Apps Airplay Stops when IPad sleeps

IPadNParadise

macrumors 6502a
Original poster
Jan 12, 2013
517
165
I have the latest ios 10 update and a new Appletv 4 with latest update and Airplay stops when the ipad (pro 9.7") sleeps. Actually this whole new Apple tv is crap. I have to restart it constantly to fix audio with no video but other than inconvenient, that works. Restart did not fix the ipad sleep issue. Any fixes for that?
[doublepost=1487000348][/doublepost]Title should say Stops not Stoos
 

IPadNParadise

macrumors 6502a
Original poster
Jan 12, 2013
517
165
So no one else has this problem nowadays? On the web I see questions about this same issue but they are from 2010-2014. BUT even tho I have the latest tvos and ios, I tried all the suggestions I read and nothing works except setting the ipad to Never Sleep. I dont want to do that.
 

Snoopy4

macrumors 6502a
Dec 29, 2014
661
2,968
Try a restore. You'll have to sign back in to everything, but it could be your update just pooped out during the process.
 

err404

macrumors 68030
Mar 4, 2007
2,515
616
This is app dependent. For example the YouTube app works fine for background playback, but if you use AirPlay from the website, it usually stalls.
 
  • Like
Reactions: JeffPerrin

kiranmk2

macrumors 6502a
Oct 4, 2008
891
419
Agreed - some apps work very well in Airplay, but some (including as mentioned above, Safari) will stop when the iPad sleeps. The easiest way to sort it out is set the iPad to never sleep (and then change back to normal after watching the video). Annoying but the only way I've found to do it so far.
 

Mac 128

macrumors 603
Apr 16, 2015
5,360
2,927
Agreed - some apps work very well in Airplay, but some (including as mentioned above, Safari) will stop when the iPad sleeps. The easiest way to sort it out is set the iPad to never sleep (and then change back to normal after watching the video). Annoying but the only way I've found to do it so far.
How do you set the iPad to never sleep? I only see auto lock options under display, and the max limit there is 5 min.
 

Expobill

Suspended
May 30, 2018
1,424
927
My mouth can not recite William Wordsworth's Ode: Intimations of Immortality while i am at sleep
A single Field which I have looked upon,
Both of them speak of something that is gone:
The Pansy at my feet
Doth the same tale repeat:
Whither is fled the visionary gleam?
Where is it now, the glory and the dream?
 
  • Like
Reactions: zachlegomaniac

kiranmk2

macrumors 6502a
Oct 4, 2008
891
419
How do you set the iPad to never sleep? I only see auto lock options under display, and the max limit there is 5 min.
Settings-->Display&Brightness-->Auto-Lock-->Never Still there as of iOS 11.4.1
 

Mac 128

macrumors 603
Apr 16, 2015
5,360
2,927
Settings-->Display&Brightness-->Auto-Lock-->Never Still there as of iOS 11.4.1
Thanks, forgot In posted to this thread. If you have a corporate e-mail client, it can remove the “Never” option as a security measure. That’s what was going on for me. Since I have my corporate e-mail enabled on all of my devices, this is not an option for me to solve this particular problem ... unless I want to delete my corporate e-mail to stream a movie, and then re-enable it — too many unescessary steps I shouldn’t have to take.

Back to the drawing board I guess!
 

SBlue1

macrumors 68000
Oct 17, 2008
1,588
1,802
Its not app related its an iOS bug. I have the same issue with the NFL Gamepass app. Sometimes Airplay works with the iPhone screen off but 95% of the time it's not working.

I have no clue what it is that's making it work and this may be just pure coincidence but this helps the 5% of the times: I plug the iPhone into the charger, start the app, start the game, select Airplay, open the control center and click on power saving mode and then click the side button to send the phone to sleep. I have to do this 20 to 30 times to make it work so like I said it may be pure coincidence.
 

Lappen71

macrumors 6502
Nov 16, 2012
288
138
Its not app related its an iOS bug. I have the same issue with the NFL Gamepass app. Sometimes Airplay works with the iPhone screen off but 95% of the time it's not working.

I have no clue what it is that's making it work and this may be just pure coincidence but this helps the 5% of the times: I plug the iPhone into the charger, start the app, start the game, select Airplay, open the control center and click on power saving mode and then click the side button to send the phone to sleep. I have to do this 20 to 30 times to make it work so like I said it may be pure coincidence.
Yes it is.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.