AirPlay via iTunes skipping when streaming to multiple AirPort Express's

Discussion in 'Apple TV and Home Theater' started by warvanov, Mar 6, 2012.

  1. warvanov macrumors 6502a

    Joined:
    Oct 13, 2011
    #1
    I'm not sure if this is the right forum for this, but I know you guys are helpful and will know the answer.

    I'm using iTunes on an early 2011 MacBook Pro to stream music. I have one AirPort Express 'n' in the living room connected to my home theater, and one APX 'b/g' in the bedroom connected to a pair of speakers on my desk. When streaming music to either one room or the other I have no problems. However, when streaming music to both at once I occassionally experience audible skipping, or sound dropping out entirely for several seconds at a time. This is intermittent, and doesn't seem to correlate with any increased network traffic. In fact, there's usually no other network traffic at all when this happens.

    Could this be caused by mixing b/g and n routers? Would upgrading the older APX to an 'n' fix the streaming problems? Are there any quick fixes that I can do to increase network bandwith or otherwise improve network performance and fix this issue?

    Does the AppleTV have 802.11n and would it be possible to use one instead of an APX for the same functionality? (See, I tied it back into the ATV/HT Forum there.)
     
  2. Aragornii macrumors 6502

    Joined:
    Jun 25, 2010
    #2
    I don't have an answer, but have a similar problem that may shed some light.

    I have two AP expresses set up for airplay, and one of them has the skipping problem you describe. The one that skips is the one I have set up as a wireless base station, the one that doesn't skip is used solely for airplay. My suspicion is that it's the dual use as a wireless base station and as an airplay device that causes it to choke.

    Incidentally, the one that has the problems is an n router. The one that does not have problems is an older b/g model.
     
  3. warvanov thread starter macrumors 6502a

    Joined:
    Oct 13, 2011
    #3
    Interesting. However, in my case the n is the router and the b/g is just joining the network for AirPlay functionality. The problem occurs with both APX's, sometimes simultaneously, but more often with the older b/g model.

    I should add that my apartment is pretty small, and there's not more than 30 feet between them.
     
  4. warvanov thread starter macrumors 6502a

    Joined:
    Oct 13, 2011
    #4
    Sorry for the bump, but has anyone else got any suggestions?
     
  5. onebyone2 macrumors newbie

    Joined:
    May 17, 2012
    #5
    Apple Tv audio skipping when sending to more than one location

    Hi, This may not SEEM related but it worked for me.
    Set the audio options to STANDARD or DEFAULT on tv or device not holding the itunes program. (no surround sound)
    Also adjusting the speed of my Asus motherboard CPU up or down a notch or two with it's Turbov feature helped clear up almost all the skipping.
     

Share This Page