Airpod iCloud sharing

Discussion in 'iPhone Accessories' started by Analog Kid, Dec 20, 2016.

  1. Analog Kid macrumors 601

    Analog Kid

    Joined:
    Mar 4, 2003
    #1
    What's the trick here? Do we need to have some particular iCloud service enabled?

    I may not have been patient enough. I sat at my desk with my iPhone, iPad and 2013 MBP. I tried to pair with my iPad, but it didn't give me the pairing screen automagically. I gave up and paired with my iPhone (really easy) and then tried to find them on my other devices and couldn't.

    I forced pairing with my iPad, which seemed to work, but then had to rename them to match the name on my phone. That left me wondering if I'd done something wrong so I decided to start over. Still couldn't find them on my Mac. I "forgot" the device on my iPad and my iPhone.

    Now when I tried to re-pair my phone specifically referred to them as "Not Your Airpods" and made me hold the button on the case to pair. That was a little unnerving. I kind of felt like they were holding a grudge or something...

    Then had to hold the button to re-pair with my iPad, and again to see them on my MBP.

    It's possible that there's a firewall issue with the MBP-- I don't get iCloud email, but I do get iMessages so I'm not sure which services are blocked and which aren't.

    They seem to be working, though it takes some manual switching to get from one device to the next and the iPad doesn't always show them as an option.

    I think most of this is a result of impatience on my part, and overeagerly fumbling around. Mostly trying to figure out how to start over and "do it right".
     
  2. Analog Kid thread starter macrumors 601

    Analog Kid

    Joined:
    Mar 4, 2003
    #2
    Turns out if you disconnect your AirPods from everything, open the case with the AirPods in place, and then press the button on the case for 15+ seconds, the little light flashes amber and appears to reset everything to factory defaults.
     
  3. Korican100 macrumors 6502a

    Korican100

    Joined:
    Oct 9, 2012
    #3
    did you make sure all your devices have on bluetooth and wifi?
     
  4. Analog Kid thread starter macrumors 601

    Analog Kid

    Joined:
    Mar 4, 2003
    #4
    Yeah, I've got it all working now. I did a full reset and started over, so I'm pretty comfortable they're configured correctly.

    I think I was just impatient to play with my new toy the first time around and the corporate firewall may have caused some problems too. They're still a little slow to appear in my iPad list, but they do if I wait a bit.
     

Share This Page