Airpods 2 on Sierra?

ericg301

macrumors 65816
Original poster
Jun 15, 2010
1,256
637
I realize that Airpods 2 require 10.14, but my work Mac is stuck on Sierra for the time being. Has anyone tried them on older OSs? Curious if they'll even pair. And if they do, what features I'd be missing out on.

My 1st gen Airpods are useless now for VOIP calls longer than 30 minutes.
 

westislander

macrumors member
Aug 17, 2011
66
27
Montreal, Quebec Canada
I'm running High Sierra (MacOS 10.13) on a 2011 MacBook Air and my AirPods 2 connect just fine.

I just don't get:
  • the AirPods animation when I open the lid on the case
  • Hey Siri functionality
  • They won't auto connect to my Mac if my AirPods are connected to my iPhone or any other device. I'd have to manually connect them.
  • You have to remove both AirPods out of your ears for the sound to pause instead of just one.
Once paired and connected, I'm able to customize the double tap functionality on the right and left side with skip, forward and pause actions but not Hey Siri.
 
Last edited:
  • Like
Reactions: skadd

ericg301

macrumors 65816
Original poster
Jun 15, 2010
1,256
637
I'm running High Sierra (MacOS 10.13) on a 2011 MacBook Air and my AirPods 2 connect just fine.

I just don't get:
  • the AirPods animation when I open the lid on the case
  • Hey Siri functionality
  • They won't auto connect to my Mac if my AirPods are connected to my iPhone or any other device. I'd have to manually connect them.
  • You have to remove both AirPods out of your ears for the sound to pause instead of just one.
Once paired and connected, I'm able to customize the double tap functionality on the right and left side with skip, forward and pause actions but not Hey Siri.
ok just got mine with sierra. double taps launches siri. no way to change that. music will pause when i take one out though.

they do sound better than G1s.
 

Nismo73

macrumors 6502a
Jan 4, 2013
865
440
When I first got the new AirPods the other week i couldn't get them to connect to my iMac 2012 with Sierra but after the latest little update they are working.