AirPods Conflicting with Bluetooth Mouse

Discussion in 'macOS Sierra (10.12)' started by Exile714, Jan 5, 2017.

  1. Exile714 macrumors 6502a

    Joined:
    Jan 14, 2015
    #1
    Using AirPods with my MBP16 and a Bluetooth mouse (Logitech MX), I get a problem where for a few seconds every 2-3 minutes my mouse stops functioning. Anyone else experience something like this or know a setting I should tweek to get this to stop?

    Before you ask, mouse works fine without AirPods being used (haven't tried other Bluetooth audio though), and AirPods work fine with or without the mouse.
     
  2. checkler2173 macrumors newbie

    checkler2173

    Joined:
    Feb 2, 2017
    #2
    Yes. It not just you. I stopped using AirPods with Mac because of it.
     
  3. CTHarrryH macrumors 68000

    Joined:
    Jul 4, 2012
    #3
    known issue with bluetooth and airpods - rumor that airpods update from yesterday may fix. leave airpods in case near connected phone and it is supposed to update.
     
  4. gwang73 macrumors 6502a

    gwang73

    Joined:
    Jun 14, 2009
    Location:
    San Francisco Area
    #4
    Updated my AirPods and the mouse still drops out, not as often as every 2-3 minutes though. Filed a bug report with Apple but haven't heard back from them.
     
  5. MacGizmo macrumors 65816

    MacGizmo

    Joined:
    Apr 27, 2003
    Location:
    Arizona
    #5
    This has nothing to do with AirPods. It's a known bug with nearly all 3rd party mouse/keyboard makers who use the older Bluetooth spec (which is nearly all of them). They are aware of it, and have no plan to fix it. The work-around is to use the stupid/annoying USB Unified Receiver instead of the Bluetooth (which kind of defeats the purpose, right?!!!)

    If you still have that little USB receiver that came in the Logitech MX box, plug it in and remove the mouse from the Bluetooth prefs and see if the problem goes away. I'm betting it will.
     
  6. budfoot macrumors regular

    budfoot

    Joined:
    Jul 1, 2008
    Location:
    Boston, MA
    #6
    Running beta macOS? I had this issue without AirPods on the latest beta.
     

Share This Page