Airpods Connection Inconsistency

Discussion in 'iPhone Accessories' started by tomaustin44, Mar 2, 2017.

  1. tomaustin44 macrumors regular

    Joined:
    Oct 26, 2013
    #1
    So I was impressed when Apple announced that the new W1 chip would bring an end to the usual bluetooth nightmare of pairing, unpairing, manually connecting etc... After over 2 months with the Airpods I personally don't think the W1 and Airpods in general are performing that well at all in this regard. Here's a list of problems I experience fairly regularly (at least a few a day):

    - Failure to appear as an output device option in macOS (this happens very regularly)
    - General failure to connect from macOS (requires repairing or manual connection via Settings)
    - Ear autodetection failure (normally requires repairing and then fine)
    - Ear detection sometimes works with one Airpod but not the other

    I know these aren't an issue with my particular set but rather just the usual 1st gen/iCloud syncing/having loads of devices issues. Still, am interested to hear if anyone else has problems as they're certainly not as seemless as advertised. Very happy with everything else though!
     
  2. rugmankc Contributor

    rugmankc

    Joined:
    Sep 24, 2014
    Location:
    Dayton, Ohio
    #2
    I have none of those issues. Have you thought about exchanging them.

    Mine pair immediately. I do only use with my iPhone though. Bose over ear for the Mac.
     
  3. Mighuel macrumors member

    Joined:
    Aug 27, 2008
    Location:
    Finland
    #3
    I just got Airpods today and there seems to be quite serious problems with them. They play music for like 1 second and then drop connection. Before the drop one of the pods crackle and pop and then goes the other. I've paired and re-paired them quite a few times and also tested on Mac but same problem. I tried to google for answers but didn't find too many people with this kind of problem. I've tried them with my iPhone 7 plus and Macbook Pro.
     

Share This Page