Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

ZeChild

macrumors demi-god
Original poster
May 14, 2012
358
279
Glasgow, UK
Has anyone else noticed issues with the Auto Switching feature, I use my iPad for Webex calls and my iPhone for business calls and the auto switch feature seems haphazard at best, sometimes it works fine sometimes it doesn’t switch at all and I have to go in and select them, I get that Webex is a third party app but surely it should switch based on sound output, got a feeling this has a few bugs that could have been sorted out during the iOS 14 beta phase😕
 

Aka757

macrumors member
Sep 22, 2016
49
39
Houston
It works beautifully for me, although I haven’t really tried with video calls. When I am switching between my iPhone and iPad for things like music or YouTube videos, it works like a dream. Hard to use other headphones now without it.
 

Abbsta

macrumors member
Jun 24, 2010
73
17
Q. Is it also supposed to auto-switch with Apple TV? It is a bit of a hit and a miss with me especially when it comes to Apple TV. I know Big Sur is required for the Mac. Oh, I just remembered... downloading Big Sur now.
 

OriginalClone

macrumors 6502
Jul 14, 2012
396
599
Has anyone else noticed issues with the Auto Switching feature, I use my iPad for Webex calls and my iPhone for business calls and the auto switch feature seems haphazard at best, sometimes it works fine sometimes it doesn’t switch at all and I have to go in and select them, I get that Webex is a third party app but surely it should switch based on sound output, got a feeling this has a few bugs that could have been sorted out during the iOS 14 beta phase😕
It‘s been very iffy with me as well.
 

myrtlebee

macrumors 68030
Jul 9, 2011
2,672
2,237
Maryland
I have standard AirPods, an Phone SE, and a 2020 MBP, and autoswitching worked at first, now it's being stubborn. I restarted both devices. Don't understand what the issue is. I was looking forward to this feature.
 

myrtlebee

macrumors 68030
Jul 9, 2011
2,672
2,237
Maryland
Mine still doesn't work. Is anyone else still experiencing issues or know of a solution? Should I reset the AirPods themselves from the case?
 

marty1980

macrumors 6502a
Apr 22, 2011
665
525
On iOS13, my AirPods would connect really fast to whichever device last used them. I only needed to go to settings when I wanted to switch devices.

On iOS14, I have start playing sound from the device I want, place the AirPods case close to the device, open the case and wait for the power indicators to show up on the device, then I can take the AirPods out and place them in my ears. Usually, if I follow this exact procedure, it will connect. It takes 3-5 seconds for the power indicator to show up on my device where previously it was near instantaneous.

But still sometimes, I've had to put the AirPods back and repeat. And I've had to mess with Bluetooth settings.

It's been a worse experience for me on iOS14 because of this. I haven't needed the auto-switching feature while working from home. I use them mostly for my iPad, but my phone is always near. So it's just been a big inconvenience for me since updating my phone and tablet.
 
  • Like
Reactions: JaJaWa and ascender

ZeChild

macrumors demi-god
Original poster
May 14, 2012
358
279
Glasgow, UK
Well I've tried everything I can think of to fix this even resetting the AirPods, still glitches so much for seamless, was looking forward to this more than the spatial audio as most days I'm switching between webex on my iPad and personal/work calls on my phone 😢
 

ZeChild

macrumors demi-god
Original poster
May 14, 2012
358
279
Glasgow, UK
doesnt work on Big Sur it works when you use your phone but doesnt go back to the Mac, apple need to fix this 5 months beta testing for what?
Makes no sense to me I've been on the Dev Beta since it was released and they never tested the auto switching with beta when they could have ironed out the bugs before release, beta testers only got access to it the day before iOS 14 went live.
 

ZeChild

macrumors demi-god
Original poster
May 14, 2012
358
279
Glasgow, UK
On iOS13, my AirPods would connect really fast to whichever device last used them. I only needed to go to settings when I wanted to switch devices.

On iOS14, I have start playing sound from the device I want, place the AirPods case close to the device, open the case and wait for the power indicators to show up on the device, then I can take the AirPods out and place them in my ears. Usually, if I follow this exact procedure, it will connect. It takes 3-5 seconds for the power indicator to show up on my device where previously it was near instantaneous.

But still sometimes, I've had to put the AirPods back and repeat. And I've had to mess with Bluetooth settings.

It's been a worse experience for me on iOS14 because of this. I haven't needed the auto-switching feature while working from home. I use them mostly for my iPad, but my phone is always near. So it's just been a big inconvenience for me since updating my phone and tablet.
That's way worse than what I'm experiencing, have you tried a full reset of your AirPods:

 

MayaTlab

macrumors 6502
Dec 12, 2007
273
242
So far for me, auto switching works from my Mac (MacBook Pro 13" mid-2014) to my iPhone very reliably, but not the other way round (it never auto switches from the iPhone to the Mac, despite the setting being appropriately set in the preferences pane). I'll see how it evolves over time.
 

Frankfurt

macrumors 6502a
Dec 4, 2016
506
488
USA
Works spotty and with delay. Worst for me is that I typically have Teams video calls on the iPad, then once ended I get an audio call and pick it up with the phone. Hardly ever moves seamless. I also think it worsened with 14.2.
 

JWGold

macrumors member
Sep 25, 2017
60
30
United States
I hate it and I finally had to turn it off. Most of the time, when I am taking a call on my iPhone, I might be perusing documents or the internet on my iPad. I have lost count of how many times, I would suddenly lose connection on my phone call mid sentence only to discover the AirPods had switched to my iPad. Much happier now that this bug is disabled.
 
  • Like
Reactions: Northeast Cold

ZeChild

macrumors demi-god
Original poster
May 14, 2012
358
279
Glasgow, UK
Just bought a pair of Beats solo pro's and they switch over without a problem?!?

Also hate that when I'm on Webex calls and a call comes in it silences the Webex until I decline the incoming call, again I know it's a 3rd party app but the device should know I'm on a call, if I'm on a messenger call I'll get the call waiting sound but it won't cut off the audio😕
 

robjulo

Suspended
Jul 16, 2010
1,623
3,156
Auto switching is more of a hinderance in its current state than helpful. Constantly fighting with the phone and APP to get the calls to go through the APP rather than iPad and my car.

For example, phone call comes in while I'm looking at the iPad, by the time it actually switches to the phone, call is missed.

In the car, I'm constantly fighting the phone to get the call to go through the APP rather than the car. I'll even click on the APP in the audio portion.....sometimes it refuses to switch, others it will switch from the car to the APP, only to switch back to the car after a minute or two.
 

GigabitEthernet

macrumors 6502a
Jun 21, 2013
821
587
United Kingdom
Doesn't seem to auto-switch on macOS at all, although it does swap a lot quicker when you do switch it manually, which suggests to me it's not an issue with the connection itself. Switches to the iPhone (from the Mac) beautifully.

Very disappointed overall.
 

anthony13

macrumors 6502a
Jul 1, 2012
747
677
Mine has never worked. I always have to select it. I hoped iOS14 would solve it. Nope. Just doesn’t work.
 

rayyu882

macrumors member
Jan 18, 2010
95
3
I dislike this auto switching feature, gladly I can turn it off. I could be on an iPhone call while my iPad play a video, it will then abandon my call and switch to the iPad. And when I try to switch it back, it will refuse to do that unless I turn off bluetooth on the iPad, it's super annoying.

It's a neat feature when it works, but for me it switch to the wrong device enough times that I stop using it.
 
  • Like
Reactions: Northeast Cold

xxray

macrumors 68000
Jul 27, 2013
1,798
4,096
It's so buggy for me. Sometimes it works, sometimes it doesn't. It will say in control center that the AirPods are connected via bluetooth, but then the AirPods icon won't show up in the volume slider and audio doesn't actually play via the AirPods. Often, my iPhone will just freeze for like 5-10 seconds while it tries to automatically connect to my AirPods. It's a mess.
 

ascender

macrumors 601
Dec 8, 2005
4,035
1,931
Its been really bad for me - unpredictable which is the worst thing as I can't accurately host a Zoom call just now because my AirPods bounce about from laptop to phone for the first few minutes.
 

Northeast Cold

macrumors newbie
Nov 24, 2020
8
3
Here is the issue I have had on both the Mac OS and iPad OS. I will be on a business phone call using my AirPods connected to my iPhone. If I then start to use my computer or iPad the AirPods disconnect from my phone and connect to the Mac/iPad. It is the most frustrating experience. I had to turn off the auto connect feature to stop this from happening. I don't understand why if you are in a active phone call or listening to something it would just assume you want to automatically connect to another device.
 
  • Like
Reactions: rayyu882

ascender

macrumors 601
Dec 8, 2005
4,035
1,931
Here is the issue I have had on both the Mac OS and iPad OS. I will be on a business phone call using my AirPods connected to my iPhone. If I then start to use my computer or iPad the AirPods disconnect from my phone and connect to the Mac/iPad. It is the most frustrating experience. I had to turn off the auto connect feature to stop this from happening. I don't understand why if you are in a active phone call or listening to something it would just assume you want to automatically connect to another device.
That's exactly what's happening to mine. I really had no issues with how they worked before this feature.

I guess I'll disable auto connect and hope I remember to turn it back on when its fixed!

Edit... how do you disable it please?!
 
Last edited:
  • Like
Reactions: Northeast Cold

T-Bob

macrumors 6502a
Oct 23, 2013
655
354
Was working here (mostly) but broken in latest beta, perhaps needs to re-pair if its not a widespread issue.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.