Airpods USB driver, windows

Discussion in 'iPhone Accessories' started by kognos, Dec 22, 2016.

  1. kognos, Dec 22, 2016
    Last edited: Dec 22, 2016

    kognos macrumors member

    Joined:
    Aug 17, 2013
    Location:
    Oregon
    #1
    Since Windows won't charge devices without proper drivers, does anyone else have an issue with their Airpods registering in Windows?

    I fully admit this problem might be just me, but I have my airpods as "USB Input Device" with a yellow triangle on it. I can force update a driver and it might find a generic driver that works, but every time I unplug the Airpods and re-plug them in, I've got a yellow-triangle "USB Input Device" and the airpods case fails to charge.

    Edit: Windows 10 specifically
     
  2. kognos thread starter macrumors member

    Joined:
    Aug 17, 2013
    Location:
    Oregon
    #2
    Digging further into this, it appears that there's no driver for windows yet, unless I'm mistaken, does anyone have their airpods hooked up to a windows machine and getting charge to the case?
     
  3. dontwalkhand macrumors 601

    dontwalkhand

    Joined:
    Jul 5, 2007
    Location:
    Phoenix, AZ
    #3
    I am not sure about this as we only have Macs, but did you try to install iTunes and see if that worked?
     
  4. LasersGoPewPew macrumors regular

    LasersGoPewPew

    Joined:
    Sep 12, 2014
    Location:
    PDX
    #4
    I have my AirPods case plugged into my work PC running Windows 7 and it's charging just fine.
     
  5. kognos thread starter macrumors member

    Joined:
    Aug 17, 2013
    Location:
    Oregon
    #5
    Windows 10 does not charge devices without drivers. That explains windows 7.

    iTunes is installed, latest version.
     
  6. rockyromero macrumors 6502

    rockyromero

    Joined:
    Jul 11, 2015
    #6
    I'm unable to connect Airpods to a W10 bootcamp MAC.

    Rebooting as a MAC, works perfectly well with Airpods.

    Must be drivers that I need from Windows.

     
  7. ohio.emt macrumors 6502a

    Joined:
    Jul 18, 2008
    Location:
    Ohio
    #7
    I just tested and my Windows 10 laptop is charging them. I didn't install any drivers, it was automatically recognized as a HID device with 2 entries. One was HID-compliant vendor-defined device, and the other USB input device.

    Edit: Other devices that show under the HID sections for me, are two other Bluetooth headphones and a Logitech gaming virtual keyboard and mouse.
     
  8. Wolfent macrumors newbie

    Joined:
    Oct 1, 2016
    #8
    I'm not in the habit of necromancing threads, but has anyone found a solution yet? Really irritating issue :/

    I recently upgraded my PC, and now my AirPods case won't charge anymore. It worked fine on my last build, but now it's just... stopped? Same issue, gets recognized as a "USB Input device" that isn't working. The case itself lights up orange like it's charging, but gets no charge.

    Front and back USB ports don't work. What will work is my pice USB card, but that's a pain since the lightning cable is barely long enough to reach.

    I've been trying various drivers included in windows, but none of them are working. None of them will supply a charge. Not sure why the pice card is working and the motherboards and front panel wont.
     
  9. acayon macrumors newbie

    acayon

    Joined:
    Sep 1, 2016
  10. sactownbwoy macrumors 6502

    Joined:
    Aug 28, 2008
    #10
    I don't have the above mentioned problem. I plugged Airpods into my Win10 PC and it instantly recognized them as "Airpods charging case"
     

Share This Page