Airport and Self-attributed IP

Discussion in 'Mac Accessories' started by feijoeiro, Sep 1, 2008.

  1. feijoeiro macrumors newbie

    Joined:
    Sep 1, 2008
    #1
    Hi guys, my Macbook always worked just fine until I decided to install an Time Capsule. Since then the airport always connects to my home wireless network but it puts an self-attributed IP: 169.254.158.226.

    No matter what I do, I change this ip address but in a feel minutes the airport changes again this ip address.

    Does anyone could give me some tips about what to do?
     
  2. viggen61 macrumors 6502

    Joined:
    Jul 24, 2002
    Location:
    New Jersey
    #2
    Can you describe your network in more detail? Do you have only the Time Capsule, or do you also have another AirPort Base station?

    You need to check all the settings in all the devices to make sure that there are no conflicts. It sounds like you might have two devices giving out IP addresses.

    I was having difficulties with my home setup until recently. Turns out one of the problems (besides the outside and inside wiring needing work...) was that BOTH my DSL modem and my AirPort Extreme Base (saucer) were trying to do the PPOE thing at the same time. Flipped the AEBS to Bridge mode, and haven't had that problem since...

    :apple::apple:
     
  3. craigverse macrumors 6502

    craigverse

    Joined:
    Dec 8, 2006
    Location:
    Reno, NV
    #3
    Usually your computer will do that if it can't get an ip from the base station it assigns one in that range as something to fall back on. In a network computers that can't get an ip will all fall back to ip's in that range and it'll allow them to talk to each other.

    See if you can log into time capsule through airport utility or w/e and make sure it's set to assign dhcp numbers to the network.

    Or if the box that's supplying your internet is set to assign dhcp numbers turn it off for time capsule.

    If the modem is assigning them you may want to plug the cord coming from your modem into one of the regular ports and not the WAN port.

    First though, as always, try just unplugging everything waiting 30 secs and plugging it all back in.
     
  4. feijoeiro thread starter macrumors newbie

    Joined:
    Sep 1, 2008
    #4
    Well, I turned off the TC and I am working only with with the Dlink access point.

    I brought the macbook to the company where I work and it works fine with the access point here. So I believe that I did something stupid with the access point.

    I will have to check again the DHCP configurations and try to find the error...
     
  5. Cave Man macrumors 604

    Cave Man

    #5
    Make sure System Preferences > Security > Firewall is set to Allow all incoming connections.
     

Share This Page