Airport and Wireless Connectivity Issues on MBP

Discussion in 'Mac Basics and Help' started by DukeVu, Jun 20, 2010.

  1. DukeVu macrumors newbie

    Joined:
    May 30, 2010
    #1
    I've recently bought a 13" MBP 2.4ghz. At first, the wireless internet was working perfectly fine.

    However, after 2 weeks or so i started to notice some odd issues. If the MBP has been asleep for a while and I wake it up, the connection is gone and I would have to reset the modem to fix it. That isn't a major issue though.

    Now, I cannot get a wireless connection AT ALL.:mad: The airport status on top has all full bars but when I open up my network configurations in system preferences, it says that AirPort is not connected. When I open up Safari, it just states that there isn't an internet connection.
    I've tried to connect it to a friend's wireless network, and no luck. I've resetted the both modem/router and the MBP, and no luck as well. I'm all out of options!

    Does anybody have any suggestions?:(

    (I'm on the latest software update, 10.6.1)
     
  2. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #2
    The latest version (of OS X 10.6) is 10.6.4 ...
     
  3. DukeVu thread starter macrumors newbie

    Joined:
    May 30, 2010
  4. whaleonwheels macrumors newbie

    Joined:
    Apr 24, 2008
    Location:
    Santa Cruz, CA
    #4
    if you are on 10.6.4 - i believe this update did something funky to the Network Preferences. i noticed that for whatever reason my iphone (which is part of the airport network), was being prioritized as the internet connection, even though i was connected via ethernet and airport. i simply made that connection inactive. also check the airport connection priority; for me it's ethernet (if i'm connected physically), then airport.
     
  5. DukeVu thread starter macrumors newbie

    Joined:
    May 30, 2010
    #5
    Yeh, the internet on my iTouch works perfectly fine. So you're suggesting that i should re-prioritize my connection devices? How do I do that?
     
  6. whaleonwheels macrumors newbie

    Joined:
    Apr 24, 2008
    Location:
    Santa Cruz, CA
    #6
    open network preferences either by opening system preferences or by clicking on the airport icon in your menu bar. the service list is on the left: airport, ethernet, local network (if you have one setup), bluetooth, firewire (if available). click on the gear icon below the list and select set service order.
     
  7. Lokrado macrumors regular

    Joined:
    Jan 26, 2009
    Location:
    Denmark
    #7
    I noticed something funky too. Whenever I add or edit a VPN connection it drops the wifi connection untill I'm done.
     

Share This Page