airport + bt homehub = FAIL. doesn't recognise base station? please help.

Discussion in 'MacBook' started by lp283, Dec 25, 2009.

  1. lp283 macrumors newbie

    Joined:
    Dec 25, 2009
    #1
    Hi all

    I have just acquired a second-hand iBook G3 (Mac OS X 10.3.9) and I can't connect to my BT HomeHub using the AirPort. I can connect using a cable and the previous owner had no problems with the AirPort. My PC is connected to the BT HomeHub fine.

    The AirPort is on and I can see the correct BTHH network in the list. When I try to connect I get the error message "There was an error joining the AirPort network 'BTHomeHub etc." I know this is a common error message but I've been through lots of forums and haven't found any advice that has worked. I tried stuff like cleaning up the keychains and adding '$' to my password.

    It could be a problem with my password, because I've tried the Admin password on the back of the hub, the Wireless key BT gave me on the 'Wireless Settings' card, and the password I use for wireless internet on my PC. Does anyone know which one ought to work?

    When I go into the AirPort menu and click on Internet Connect, 'AirPort Power' is 'on', there is no signal, and it says 'Base Station ID: Not available'. Do I need to reset my Base Station?

    If anyone can help I will be soooo grateful. Thanks.

    **I'm a Mac newbie and I'm not a techie, so if you can help me, please be prepared to explain in detail**
     
  2. NewMacbookPlz macrumors 68040

    NewMacbookPlz

    Joined:
    Sep 28, 2008
    #2
    Despite having the correct password, are you selecting the proper type of encryption? (WEP vs WPA vs WPA2) As for which password to use to connect to the WiFi network, the one you use on the PC is the correct one, I suspect the one on the router is to login to the router to get to it's control panel.

    Also, try connecting via the AirPort downdown menu from the menubar rather than the Internet Connection application. On my iBook G4 that application gave me nothing but trouble connecting to a linksys router, but using the Menubar WiFi logo worked 100%.

    Another thing to check is that the router is setup to broadcast both b and g WiFi (802.11b/g, or mixed mode) because I believe the Airport card in that iBook is 802.11b only. You'll have to login to your router with the admin login/password and check that setting somewhere in the wireless settings menu.
     
  3. lp283 thread starter macrumors newbie

    Joined:
    Dec 25, 2009
    #3
    Thanks, but still not working

    Thanks for your help! V.grateful for advice re the password - it's much less of a hassle now I don't feel the need to keep checking three possible passwords!

    Re encryption, I selected WPA which is supported by both my ibook and router, so I don't think that's causing the problem.

    I'm using the dropdown menu, but thanks for the tip!

    I checked the wireless settings and the router is set up to broadcast both b and g wifi, so that shouldn't be a problem either.

    I am still getting my old friend the error message when I try to connect wirelessly. Can anyone help?
     
  4. lp283 thread starter macrumors newbie

    Joined:
    Dec 25, 2009
    #4
    oh yes, and

    Using iStumbler to find local wireless networks, I can see BTHH with the MAC address listed alongside.
     
  5. NewMacbookPlz macrumors 68040

    NewMacbookPlz

    Joined:
    Sep 28, 2008
    #5
    A couple more things I just thought of...

    In the DHCP setup menu of the router, sometimes you can tell the router what IP address range to allow or how many devices to allow on the network either via an absolute value or by limiting the number of IP addresses the router can assign.

    Is there any chance the router is limited to a couple/few devices by whatever the default setting is?

    Another thing is, does the router have MAC address filtering turned on, where you have to enter your computer's WiFi adapter's MAC address into the router control panel to gain access?
     
  6. lp283 thread starter macrumors newbie

    Joined:
    Dec 25, 2009
    #6
    I really really really appreciate all your help.

    I checked out the DHCP setup menu: it allows a range of IP addresses and both my laptop's wired and wireless addresses fit in the range. I can't find an entry in the general BTHomeHub menu for MAC address filtering - so I guess it probably doesn't do it?

    I also phoned BT just for the hell of it and fiddled with the settings of the router. Nothing doing.

    Argh argh argh. I still have a problem.
     

Share This Page