Airport connected but Internet not Working

Discussion in 'MacBook' started by existent, Sep 2, 2009.

  1. existent macrumors newbie

    Joined:
    Apr 10, 2009
    #1
    I am writing on behalf of my friend. Her white Macbook is having some problems connecting to the internet at a specific location.

    My macbook and other laptops connect to the internet without any problem, but she has been having problems.

    Airport connects to the network and even assigns an IP address properly, but the safari or firefox doesn't open any websites.

    I tried manually assigning IP address but didn't work either. I am not very good at solving problems with Macs so any help is welcome.

    edit: sometimes it is a bit difficult to assign the IP address, but it does end up assigning one.
     
  2. Vashed555 macrumors newbie

    Vashed555

    Joined:
    Sep 2, 2009
    Location:
    Ohio
    #2
    Usually what happens to me on certain encrypted networks is that it will somehow self-assign an IP... what clears it for me 99% of the time is clicking on the wireless icon in the tool bar, turning airport off, and then turning it back on. If this doesn't help, and this is a network that she has had to set up.. (ie WEP encryption or some other such situation), you may need to delete the connection, and then recreate it.

    Good luck!
     
  3. sonspot macrumors member

    Joined:
    Jul 19, 2009
    Location:
    Toronto, Ontario Canada
    #3
    if the connection is not encrypted, be sure that your not working offline sometimes its that simple..
     
  4. greatmaju macrumors member

    greatmaju

    Joined:
    Aug 13, 2008
    Location:
    A Little place i Call Terra
    #4
    If you are using a router, and can connect to it, try restarting the router.
    Sometimes the my router goes odd, and connects me to a Link-Local IP, yet I can't get on any webpage, so it needs a webpage.
    (Though after the Firmware update, which is worse, it now just disconnects it self from the net altogether, and boom, I can't connect to the router via WiFi.)
     
  5. existent thread starter macrumors newbie

    Joined:
    Apr 10, 2009
    #5
    It's a public wifi, so there is no encryption on it.

    Best thing that we can try is to restart the router if possible i guess.
     
  6. existent thread starter macrumors newbie

    Joined:
    Apr 10, 2009
    #6

    heh... that does come up once a while, but after unticking the work offline option, it tries to open a page, and can't.
     
  7. sonspot macrumors member

    Joined:
    Jul 19, 2009
    Location:
    Toronto, Ontario Canada
    #7
    you said its a public wifi, if i remember right you have to login, if your connecting to other networks your ok, am thinking you have to login and through the browser, something i would have to see..
     
  8. greatmaju macrumors member

    greatmaju

    Joined:
    Aug 13, 2008
    Location:
    A Little place i Call Terra
    #8
    If its anything like the router I have it'll be numbers E.G:
    123.456.7.8
    You put these in a browser window. Like a web address.
    Then login through that.
    Again, My router only asks for a password, the default being nothing. But you have to be connected to the router (Either Wired, or connected to the internet via said router for WiFi) to access it.
     
  9. AeroBar macrumors 6502a

    Joined:
    Jan 21, 2009
    #9
    this is happening to me too.

    my iMac is online but my mother's MacBook isn't
     
  10. existent thread starter macrumors newbie

    Joined:
    Apr 10, 2009
    #10

    well, I don't need to login on any other computer, so I'd imagine, she doesn't need to login as well.
     
  11. Hamid-Vista macrumors newbie

    Joined:
    Feb 19, 2010
    #11

    I had the same problem with my airport in Snow leopard 10.6.2.
    I solved it hardly with a rare solution:

    Open Network utility and point to Netstat and start Netstat.
    After about 15 sec your internet connection starts to react and in Safari you use it.

    I hope that it may be useful for you.

    bye
     

Share This Page