Airport Connection Weak

Discussion in 'MacBook' started by Dommac, Nov 9, 2010.

  1. Dommac macrumors newbie

    Joined:
    Oct 28, 2010
    #1
    Hi guys,
    I recently installed a new screen in my macbook and everything is working great except for the wireless internet connection. When I used to use the internet, I could get a signal anywhere in the house or at work, but now I can only get a signal if I'm right beside a router. I'm wondering if while I was fixing my screen I knocked a cable/connection loose or something. I'm not quite sure where the wireless card is inside. If anybody could give me a hand locating it/solving the problem, I would greatly appreciate it.
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    What MacBook (exact or/and specific model) are you talking about?

    iFixIt has some helpful guides: http://www.ifixit.com/Browse/MacBook

    And what does the AirPort icon menu have to say while holding down the Option/Alt key?
    [​IMG]
     
  3. Dommac thread starter macrumors newbie

    Joined:
    Oct 28, 2010
    #3
    It is a macbook a1181, 13.3" black. I do not have it with me at the moment, but I will try the alt-option thing tomorrow.
     
  4. Dommac thread starter macrumors newbie

    Joined:
    Oct 28, 2010
    #4
    I have identified the problem. One of the two cables connecting to the airport card came out and broke while I was changing the screen. I was able to put the cable itself back into the piece connecting to the card, but it is in no way fully assembled. How would you recommend fastening the cable and the connector? Would a piece of electrical tape suffice or would I need to solder it?
     

Share This Page