Airport connects, but internet not connecting

Discussion in 'macOS' started by heidy, Feb 10, 2010.

  1. heidy macrumors newbie

    Feb 10, 2010
    I've had my Mac for 3 years and never had a problem with Airport Express. If I did, I would usually turn it off and then on again and it solved the problem. The last two weeks I've been using a wi-fi hotspot near my home until I get a proper internet connection at home. Suddenly, my internet stopped working. The airport recognzies the link and still connects but the internet page says i'm not connected to the internet. I've tried using diagnostics and it says it can't fix my problem. In diagnostics, the first 3-4 lights turn on, but the last two are either yellow or red. I've changed the time to make sure it was correct, I've re-started the computer several times and it still doesn't work. I don't know what it is that is not working. The airport recognizes the signal, yet I get no internet connection. And I haven't downloaded anything recently. Please help!
  2. Denarius macrumors 6502a


    Feb 5, 2008
    Gironde, France
    Have you tried setting a manual DNS in your airport settings? and are pretty reliable.

    If it's 4 lights, the above should work. If it's 3 lights then it won't as there's no gateway up behind the access point.
  3. heidy thread starter macrumors newbie

    Feb 10, 2010
    It's 3 lights -- the last two remain red or orange. I don't know why it's not connecting and it's very frustrating. I've spent hours trying to fix it.
  4. Wondersnite macrumors newbie


    Jan 14, 2010
    I've got the same problem... The only way I can connect to the internet is through the ethernet port, which is kind of ridiculous. Does anyone have a solution?
  5. Wondersnite macrumors newbie


    Jan 14, 2010
    Ok, I think I got it working. I tried adding a new location in the network group in System Preferences (it's at the top). A new one named "untitled" worked fine, I guess it reset some stuff. Hope this works for the rest of you.
  6. Bazza90036 macrumors newbie

    Apr 3, 2013
    It might just be your Password!!

    Was having similar problems to the above thread. Wifi Network was showing it was connected but I could not connect to Internet. Airport Extreme was flashing AMBER.

    Modem signal was fine.
    Network Prefs showed:

    Airport: Green
    Airport Settings: Green
    Network Settings: Green
    ISP: Green
    Internet: RED
    Server: Red

    After checking with ISP and connecting to the internet via Ethernet my ISP told me that there was something wrong with my wireless router (the Airport Extreme).

    I ran Airport Utility and and it came back reporting problems.

    (IMPORTANT: A few days earlier I had re-set my email password.)

    As soon as I updated my "new" password in the Airport Utility...the airport restarted and I was good to go.

    It was as simple as entering my new password!!

    Hope that helps!!

Share This Page