Airport & D-Link DSL- G604T

Discussion in 'Mac Accessories' started by stonkpot, Jul 17, 2007.

  1. stonkpot macrumors newbie

    Joined:
    May 27, 2007
    #1
    Hey guys,

    I've just bought a MacBook, and am trying to configure it right now. It can easily see my home network (D-link G6504T wireless hub), and it asks me to enter my password.

    I enter the password CORRECTLY and it tells me the password is invalid.....

    My hub works fine with my PC (and other pcs). Can you help me ? I appreciate it's a really weird problem.

    Many thanks indeed for your time
     
  2. Angel40k macrumors newbie

    Joined:
    Jul 25, 2007
    #2
    same problem

    I am a similar problem with my MacBook Pro and the D-Link DSL-G604T. The Mac see the network but is unable to connect to it. In other side, another laptop (PC there) is able to connect to this network.

    After a lot of change on the config of my router, I have successfully connected to the router (using WEP or WPA-PSK encryption).
    Badly the connection to Internet is most time very slow without any reason (my PC laptop react really faster that the mac in the same time).

    The transfer between the two laptops (Mac & Pc) are also very slow and the connection is lost frequently.

    After several days of using, my Airport is now unable again to connect to the router. In looking in the console I found the following error message:
    Error: WirelessAssociate2() = 88001006 for network .... The operation timed out.

    In looking on Internet I discovered a lot of user having the same problem. I suspect now the driver of the AirPort device (or the AirPort itself) to be bugged.

    Someone has the solution?
     
  3. schido macrumors newbie

    Joined:
    Aug 1, 2007
    #3
    I think I do have a solution for you. At least it solved the same problem in my case. The only thing you have to do is to change the b/g Mode in the wireless performance options in your router. I selected "11g Only" and now my macbook connects perfectly to my DSL-G604T router.

    I hope this will work for you.

    Saludos
     

Share This Page