Airport does not connect to internet, various other problems

Discussion in 'MacBook Pro' started by NoWhammies!!!!!, Feb 10, 2012.

  1. NoWhammies!!!!! macrumors newbie

    Joined:
    Feb 10, 2012
    #1
    Hi -

    I'm having problems connecting (via Airport) to the internet. Ethernet works fine. This problem came on suddenly and with it came a few other problems. I've experienced a blue screen and a weird resolution change for no reason. Also, the date was set to 2001... The operating system also says I now have 10.6.6 even though the disc installed 10.6.8... Very weird. I know there is no problem with the network, since my girlfriend's computer (PC) connects fine. I've already tried resetting the router, turning airport on and off, resetting firewall, deleting com.alf file, playing with network prefs. Airport says it has a self-assigned IP and will not connect to internet, I've renewed DCHP lease... cannot figure it out. Anyone have any ideas? Thanks in advance!

    Sincerely,
    NoWhammies!!!!!
     
  2. macuserx86 macrumors 6502a

    macuserx86

    Joined:
    Jun 12, 2006
    #2
    All your problems are computer-side. You need to check on the health of your HDD. Open Disk Utility and check the SMART status (should say "VERIFIED") Also, repair permissions. (sorry if you already know how to do this, I just like to be thorough)

    Another trick is to go to Network preferences and delete the WiFi interface using the "minus" button on the bottom, then re-add the interface using the "plus" button on the bottom. Sometimes this can fix connection issues.

    If none of those work, and you don't want to re-install OS X, you can try reseting the SMC controller and see if that helps. Apple has a how-to and explanation here: http://support.apple.com/kb/HT3964
    While you're resetting things, sometimes resetting the PRAM can help. http://support.apple.com/kb/ht1379


    Good luck, hope everything works out!
     
  3. NoWhammies!!!!!, Feb 10, 2012
    Last edited: Feb 10, 2012

    NoWhammies!!!!! thread starter macrumors newbie

    Joined:
    Feb 10, 2012
    #3
    Thanks Macuserx86! I've tried verifying the disk, repairing disk permissions (while booted on the HD), repairing the disk (while booted on installation disk), re-installing the OS without erasing the HD, then completely erasing and re-installing the OS. In terms of network preferences, I've tried minusing and adding Airport, deleting and creating the network, changing the location and everything else I've already mentioned in the post. I've also tried resetting the PRAM as per your suggestion but unfortunately it did not work. I appreciate your help though.

    I live in Prague, so I can't take it to an Apple store because there isn't one here and I'm certainly not paying fifty bucks for an Apple care consultation. I'm totally completely baffled.

    This may sound crazy, but the only POSSIBLE thing I can even remotely think of is that yesterday (the day before this problem started) I opened a package containing a bare circuit board near the computer and left it near the computer all night. I've heard of ESD (electrostatic discharge) damaging sensitive electronics and I know that when handling a circuit board its best to try to avoid static... but could an ESD sensitive circuit board somehow damage the airport card inside my computer? It was sitting quite close to the computer...

    I really don't know. But it's the first time anything like this has happened so it's a strange coincidence.
    I also wanted to mention that I can connect to the actual network (router) and get full bars followed by an exclamation mark and no internet connection. It says "self-assigned IP address".
     

Share This Page