AirPort Express can't connect to secured network

Discussion in 'Mac Basics and Help' started by Sheeds, Jul 24, 2009.

  1. Sheeds macrumors member

    Sheeds

    Joined:
    Sep 15, 2008
    Location:
    Ottawa
    #1
    I just bought a second hand AirPort Express.
    After trying again and again and failing to connect to my home wireless network which has a password, I tried again after disabling the password, and it worked fine, I'm playing music via iTunes through it right now.

    Problem is, I'd obviously prefer a secured network, why can't I connect to a secured network? I'm using a Linkseys WRT160N Router as a base.

    Thanks a lot!
     
  2. LTX macrumors regular

    LTX

    Joined:
    Dec 25, 2008
    Location:
    Vancouver, BC, Canada
    #2
    What security mode was the AirPort Express using before you disabled it? When the Mac asks you for the wireless password, I believe it also lets you choose the security mode that the network is using. Make sure those match.

    For best security, use WPA2 Personal.
     
  3. Sheeds thread starter macrumors member

    Sheeds

    Joined:
    Sep 15, 2008
    Location:
    Ottawa
    #3
    Solution

    I was able to find a solution, so I'm posting it for others if they have this problem.

    I disabled the password for my network and set up the express using the utility, then in the Airport Admin Utility I changed the settings to connect to my network with a password, then I actually set up the password on the router. And it works fine now, a little muddled, but it works perfectly!

    I'm also now using WPA2 Personal now, I was using WPA Personal before.
     

Share This Page