AirPort Express - Charging a 2nd Gen iPod Touch

Discussion in 'Mac Accessories' started by Kaethis, Jan 13, 2009.

  1. Kaethis macrumors newbie

    Kaethis

    Joined:
    Jan 13, 2009
    Location:
    Canada
    #1
    Hello, MacRumors Forum!
    A MacRumors Newbie, but a Long-Time Visitor,


    I recently purchased an AirPort Express. My reason for this was:

    a) for the convenience of having a portable 802.11n Wireless Router wherever I needed one.
    b) to charge my iPod Touch (2nd Gen) when not connected to my Laptop.

    I was initially going to buy an Apple USB Power Adapter, but after I found them Out of Stock, I saw an AirPort Express and thought "Eh. Why not...". Many people on the Apple Store had claimed that their iPod or iPhone was successfully charged by the device's USB port. I picked it up.

    After going home and plugging it in to the wall, taking a couple minutes to connect it to my existing wireless network, and connecting it to my iPod via an iPod connection cable, I soon realized "Hey! This isn't charging my iPod!". When examining the iPod's Battery Indicator that the top right corner, it kept switching from the Lightning Blot to the Power Plug icons. Weird.

    Although I have no intention of returning it (It's actually pretty damn cool!), and know very well that I'm probably going to have buy a USB Power Adapter, I'm wondering; has anyone else been successful at charging their iPod with the AirPort Express' USB port?

    Thanks,
    Matt
     
  2. Kaethis thread starter macrumors newbie

    Kaethis

    Joined:
    Jan 13, 2009
    Location:
    Canada
    #2
    No? Nothing?
    Alrighty then. Back to BestBuy I go
     
  3. macamania macrumors newbie

    Joined:
    Jan 25, 2009
    #3
    Kaethis, I have the same thing happen when trying to charge my 2nd Gen iPod Touch with the AirPort Express (802.11n).

    Thought it would be nice to have the iPod charge on top of my stereo between the few song selections I was making from iTunes with the Remote application.

    Thinking it wasn't working because I had Wi-Fi and Remote running, tried charging it with Wi-Fi off and running no apps. Still no luck.

    If anyone has had luck charging 2nd Gen iPod Touch with the AirPort Express USB port please tell me.
     
  4. ZMacintosh macrumors 65816

    ZMacintosh

    Joined:
    Nov 13, 2008
    #4
    im not sure what it is but the USB port on there seems to be very very picky.
    my AEBSn seems to do it fine.

    the express i use for remote speakers doesnt give it enough charge and also the USB port on the AEX is not good for most USB Speakers ive tried hooking upto, i was testing some older computer speakers that had an aux cable and were powered by usb...so im assuming the AEX doesnt send enough power to the port
     
  5. MattZani macrumors 68030

    MattZani

    Joined:
    Apr 20, 2008
    Location:
    UK
    #5
    The USB Port is designed for Printers only, so i would assume it outputs very little voltage at all, as there isnt a USB Powered Printer.....
     
  6. gmk macrumors newbie

    Joined:
    Feb 28, 2009
    #6
    Charging from 802.11b/g

    The annoying thing is that an older Airport Express will charge your ipod. I've been using an ipod touch as a remote to drive itunes from the computer over the wireless network. Used to plug it into the USB port in an old airport express, 802.11b/g, and it charged great. But the music was cutting out occasionally, so I bought a new airport express to see if it would help (hasn't really). And now I can't charge the ipod touch -- same issues you have.

    As Roseanne Roseannadanna used to say on SNL: If it's not one thing it's another.
     
  7. Hoss Cartwright macrumors newbie

    Joined:
    Apr 20, 2009
    #7
    Hi there from Germany,

    I had also bad luck with APE 2009 Model and had to learn my lesson.

    I lend a older versin from a friend and tried out if I can charge a ipod touch 2nd generation with APE. The old model worked fine and charged the ipod touch. This model has Firmware 6.3.1

    The 2009 Model with 802.1n and Firmware 7.4.1 doesn't charge the ipod anymore. I'm very disapointed because this was a nice feature to save space and further costs for a extra power adapter.

    It's nice to stream the music to my stereo but the USB charging feature was a very helpfull gimmick. I don' understand why Apple changed this with the new APE. :(

    Maybe I will ask my friend to change his APE with mine.

    Regards,
    H. Cartwright
     
  8. yetinut macrumors newbie

    Joined:
    Dec 25, 2009
    #8
    Possible fix

    Hey Matt,
    Is your airport express configured for a printer? I think you might have to configure it that way in order to "turn on" the USB port. I have an older 802.11g express that is configured that way and it charges my ipod touch.
    John
     
  9. yetinut macrumors newbie

    Joined:
    Dec 25, 2009
    #9
    Just confirmed new express will charge ipod touch

    Matt,
    I just plugged my ipod touch into a new 802.11n airport express that is configured with a printer and it charges!

    John
     

Share This Page