Airport express doesn't play nicely when sharing an internet connection! HELP!

Discussion in 'Mac Accessories' started by TheMac19, May 23, 2005.

  1. TheMac19 macrumors regular


    May 13, 2004
    I've got an Airport Express, and for some reason, it just isn't sharing our high-speed internet very well. It'll work for a few hours, (green light), then not work for a few hours (flashing orange light) and so on. For weeks.

    The broadband modem consistantly reports an acceptible signal and IP address, and when I unplug the ethernet cable from the APE and plug it into my an iBook, the ibook can surf fine. (meaning that the internet is there to be had, just not being distributed properly by the APE...)

    We're running two windows machines and two macs on the network, and there seems to be no rhyme or reason as to when it'll go down. (Both macs are up to date (10.3.9, and firmware in APE has just been updated to 6.1.1) I've downloaded big files overnight without a hitch, and other times it'll quit 5 times in a few hours. None of the settings have been changes, etc.

    Which leads me to think, interference maybe? Cordless phones, mobile phones, microwaves, etc? But not so sure... When I go into the Airport utility, (and the airport is flashing orange), it yields no IP info. It's as though it's not getting an IP address. (Which it should because when I plug that same ethernet cable into the iBook, it gets an IP address fine...) [And Yes, if I run that utility when the airport is all good (steady green) it shows the IP address.]

    My (relatively uneducated) determination here is that microwaves, cell phones, cordless phones, etc can't be to blame, since the APE should be getting the IP through the ethernet cable, right?

    Long story short... Why doesn't it work!?!?!? (I'll now get back in my wahhhmbulance and go have the obligatory networking-woes-beer.)

    As always, many, MANY thanks to any and all who can offer a helping hand or a few kind words of advice...

  2. elfin buddy macrumors 6502a

    elfin buddy

    Sep 16, 2001
    Tuttlingen, Germany
    This or that...

    Since no one else seems to be replying, I'll do my best to help. I used to have a bit of trouble keeping a reliable connection with my APE. Back at university, it would randomly stop streaming music, or just go offline (as in, stop working altogether). In extreme cases, it would 'disappear' altogether so that i couldn't identify it with Airport Admin Utility, and even upon restarting it it wouldn't appear. In these cases I just held down the reset button for five seconds or so, and started anew.

    As you can imagine, I found this extremely annoying (and sometimes embarrassing, thanks to Windows users always trying to knock my hardware). I did a bit of experimenting, and found that my network would slow down or get knocked off completely whenever my neighbours used cordless phones (of the 2.4GHz variety, since 802.11b/g also uses the 2.4GHz band) or certain cellular devices. I don't know why cell phones would hurt it, but a friend of mine had a cell phone that seemed particularly powerful, as we were able to predict incoming calls by turning on a set of speakers and waiting for distortions, or watching for when my network would die. Sure enough, seconds after this anomalous activity, his cell phone would ring. After leaving university for the summer, my problems have more-or-less evaporated and I've had next to no trouble with the network dying or music stopping. (note: we have no 2.4GHz cordless phones or cell phones in the house)

    With my ADSL connection here at home though, I have had trouble connecting my dad's old iBook to the internet through my APE. AirPort is supported on his iBook (dual USB), but he didn't get an AirPort card with his and opted for a D-Link USB 802.11b adapter to get wireless. There seems to be some incompatibility since he can't instruct the APE to connect with his D-Link adapter. I called D-Link, who were extremely unhelpful and blamed my troubles on poor or non-existent USB drivers on the iBook. We bought a D-Link wireless router to try to fix the problem, but we can't even get it to activate :rolleyes:

    With a permanent internet connection like I had at university (i.e., not ADSL, where you still have to dial a PPPoE server), I had no trouble serving up wireless internet to all of my friends with my APE, regardless of the system they used. Actually, there was one guy with a Dell that was such a piece of s*** that it actually managed to bring down my network on several occasions (I kid you not), but I banned him from the network and had no problems thereafter with people trying to connect.

    My best advice to you is to go into your Airport Admin Utility and mess around with the settings until you get something that looks like it should work. Also, try turning on Interference Robustness, if you haven't done so already. Though unlikely, security might be an issue too. If you're running an open network without WPA and you're in a populated area, there could be people trying to leech off your APE and cause havoc. Unlikely, yes, but possible. Good luck!
  3. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    elfin buddy pretty much has it all covered. Just have a go at broadcasting on different channels because unless it's a hardware failure, which is pretty unlikely, it'll probably be an interference problem.
  4. kwg macrumors newbie

    Mar 30, 2006
    Download Firmware

    Had the same problem with the Airport Express not showing IP when connected to my ADSL Speedstream modem.

    When connecting my mac directly to the modem, everything worked.

    After downloading firmware version 6.3 and uploading to the Airport Express. Things worked as they should.

    I do not think that wireless interference should mess with the airport's ability to obtain IP from the DSL modem via DHCP.

Share This Page