Airport Express + Mountain Lion = Delay

KLNGNBRG

macrumors newbie
Original poster
Aug 28, 2012
2
0
Anyone else experiencing a noticeable delay when sending audio from mountain lion to an airport express ?

It doesn't matter which application is producing the sound on the mac, when the airplay speakers are connected there is a delay of 1-2 sec.

Everything is running on a blazingly fast WiFi, so that shouldn't be the problem.

I'm connecting to the speakers by pressing the "speaker" icon in the topbar + "options key" and then selecting the speakers connected to the airport express

I'm trying this on a Macbook Pro 15" from Early 2011
 

dilito

macrumors newbie
Sep 2, 2012
3
0
same problem on Macbook Air mid 2011 with M Lion. I never had Airport Express with previous versions of OS X to confirm if this is normal. (I have not the latest AirPort Express model but the previous one)
 

twintin

macrumors 6502
Aug 10, 2012
483
41
Sweden
I would say that's pretty normal and part of the protocol implementation (has always been that way as far as I know). Same delay can be heard on Windows too when running with Airfoil.
 

KLNGNBRG

macrumors newbie
Original poster
Aug 28, 2012
2
0
I haven't tried the airplay with the Apple TV, but if only transmitting sound is causing a delay, then I can't imagine it will work nicely with both video and audio at the same time.

But for some reason people don't seem to complain about this?
 

dilito

macrumors newbie
Sep 2, 2012
3
0
Today i figured out that the problem does not exist when streaming from iPhone 4...