Airport Express Port Forwarding

Discussion in 'Mac Accessories' started by MaC)AnDa, May 3, 2005.

  1. MaC)AnDa macrumors newbie

    May 3, 2005
    Hello i Just got airport express and it is great. There is only one problem. I play a game called Warcraft and am unable to "host" games on it because i need to open/foward some ports and i have no idea what ports to open or what to do . PLease reply if u have any idea. Thankyou for your time

  2. itisamee macrumors newbie

    Feb 23, 2006

    I found the below info. on another forum. Hope it helps. I needed to figure out port forwarding as well...I did it...but havent tested it yet. My internet is still working after the changes thats an improvement:)


    If you have Mac OS X 10.4, then I've found that the easiest way to set up port forwarding on the Airport Extreme/Express is to use a fixed IP address for your computer and use the NAT Port Mapping Protocol. First, ensure that your ADSL modem is not used as a router (many people have BOTH their router and Airport setup as a router. For example, both the Zoom 5660 and DSL 300T are ADSL modem /routers: ensure that they are set in to a mode such as "bridge": essentially, this means that your Airport Express/Extreme RECEIVES the IP address that your ADSL provider gives you.)

    Then, to set up the Airport for port forwarding, do this:

    1. Log into Airport Admin Utiity, and choose the Network tab. Choose Distribute IP addresses, and Share a SINGLE IP address. Then choose use addressing.

    2. Under the Airport tab, choose Base Station Options. Tick the following:

    Enable SNMP Access
    Enable Remote Configuration
    Enable Default Remote Host at
    Enable NAT Port Mapping Protocol

    3. Goto the Internet tab to make a note of the DNS servers (these are for your ADSL provider: they should be in grey to the right of the screen: if they are not, do not worry.)

    Save the configuration.

    Your internet connection won't work now: you need to give your computer the fixed IP address chosen above. To do this:

    4. Goto System Preferences, Network, then TCP/IP.

    Your connection will probably be set up Automatically using DHCP.

    First, make a note of the Subnet Mask (will probably be

    Then, change the Configure IPv4 tag to: Manually

    IP Address:
    Subnet Mask: (whatever you noted above, eg:
    Router: (this is the Airport's IP Address)
    DNS Servers: your ADSL provider's servers (from part 3: if you do not have them, phone your ADSL provider, or try using: and

    5. Save the settings (Apply Now) then goto Show All and Sharing, then choose the Firewall tab.

    Ensure the Firewall is ON, then choose New... to choose a new Port (eg: 9090).

    Update and restart your computer.

    Transmission is great: on a 1MB connection, I'm consistently getting download speeds of 90-100K (as opposed to Aquisition's 20-30k).

    Keep up the good work!!
  3. pixelvandal macrumors newbie


    Sep 6, 2006
    Bris Vegas
    Thankyou, thankyou, thankyou

    OMG - finally a solution - thankyou soooo much...., now if only I could fix the PPPoE connection - disconnection - negotiating issues I would be a happy man!!!
  4. hazlgreen macrumors newbie

    Feb 18, 2007
    Has anyone been successful with the New Airport Extreme Base Station with 802.11n?

    I have it, but the new Aiport Admin is a bit different and I cannot seem to get things to work right.

    I want Azerus to work again...

    Please tell me that someone has a solution for me.

  5. donkeyhotay macrumors newbie

    Feb 23, 2007
    Thank you, thank you, thank you...

    Yes, I'm grateful! I was so far over my head, I thought for sure I'd never get this figured, but itisamee's step-by-step process not only worked, it worked the first time!!! I've spent the past two days wrestling all sorts of technology demons. Your post was an absolute lifesaver! All the best.
  6. Dopeyman macrumors 6502a

    Sep 5, 2005
    Los Angeles!
    Ok... instead of creating a new thread, I thought I'd continue on this one...

    I'm having probs opening the Windows Sharing and/or the Personal File Sharing port on the new Airport Extreme router...

    I keep getting that yellow exclamation mark once I select the Windows Sharing option...

    As you can see from the pics, the ports are already open via the sharing prefs... I still get those errors if the ports are closed in the sharing prefs...

    What am I doing wrong??

    And yes, I do fix the Private IP Address...

    HELP!!!! TIA!!

    Attached Files:

  7. sokrates macrumors member

    Oct 1, 2006
    in my eyes the airport extreme suxx, it's port forwarding options are totally limited and simply don't work, i've used numerous routers, never a problem, and now nothing works, i have opened the ports, but azuereus for instance just doesn't work, it gives me error messages all the time, transmission again, works but slower as it should be working.... when i check port 9090 for instance it tells me that its running in stealth mode... i don't want it to be in stealth mode i want it to be open ffs....
  8. donkeyhotay macrumors newbie

    Feb 23, 2007
    Fixed Azureus. Broke FTP.

    Hi Gang.
    I followed itisamee's excellent instructions and for the first time have a BitTorrent client that works as it should with excellent upload and download speeds.
    However, in doing so, I managed to "break" my ability to FTP. I use DreamWeaver and Captain FTP, and when I try to connect, I get timeout errors. Since I now have my Mac firewall enabled, I know that that's porbably the issue here. I've tried opening the FTP Access Port (System Prefs > Sharing > Services) which controls Port 21, but that hasn't solved it.
    If I disable my firewall completely I get FTP services back.
    I'm having trouble wrapping my head around all this, so if someone can help, I'd really appreciate it.
  9. clix101 macrumors newbie

    Mar 21, 2007
    Hey, I found the above info on port forwarding very helpful! but only one problem :( When i test the port on azureus i get: Testing port xxxxx ...
    NAT Error - Connection attempt to aborted: timed out after 20sec.

    Does anyone know how i can solve this problem? I've forwarded the port in the firewall, and even switched it off. Do i need to quit and start up azureus again everytime i do this for it work?

    TIA my fellow :apple:'ers
  10. donkeyhotay macrumors newbie

    Feb 23, 2007
    Most Useful Port Forwarding Info I've Found...

    ...while the solution presented here seemed to work, I discovered that while Azureus confirmed that a chosen port was forwarding correctly, it actually wasn't (my torrents would stop seeding, and there were many problems).

    Instead, here is a summation of the info I found. Azureus is now working exactly as intended and I'm getting remarkably high share ratios. I'd strongly recommend reading this material. The time invested turned out to be well worthwhile for me. As you'll see most of these links come from Those folks have done a tremendous job of documenting this process for all types of modems/routers and all types of applications.:

    1. Overview of port forwarding:

    2. The Port Forwarding Progression

    3. Instructions for Airport Extreme using Azureus:

    4. Good Port Choices:

    5. Instructions for Airport Extreme using Azureus (Continued)

    6. How to set up a static IP address on a Mac OS X v10.4

    7. Change the Airport Base Station Settings

    8. How do I know if I've done it right?
    1. Open BitTorrent Client.
    2. Then go to this website,*
    If you get 'Stealth', or 'Closed', the you haven't forwarded correctly.
    If you get 'Open', then you have successfully port forwarded!
    *Substitute whatever port you opened in steps 3 and 5.

    9. NAT Port Mapping Protocol
    Note: Be sure to check Azureus > Options > Plugins > NAT-PMP > Enable AND Airport Admin Utility > Configure > Airport > Base Station Options > Enable NAT ...

    Hope this helps. Note that while you're jumping around a bit from a page to another, then back again, it's critical (especially for a complete newbie like me) to do this to understand how to do it and why you're doing it.

    I can't promise this will work for you, but it was highly successful for me.
  11. hazlgreen macrumors newbie

    Feb 18, 2007
    Still hoping to find someone that knows how to setup the New Airport Extreme (802.11n) for port-forwarding.

    I have my old Airport Express' working, but the new Airport Extreme (and new Airport Utililty) have me stumped.

    Anyone, Anyone?

  12. macleod199 macrumors 6502

    Mar 10, 2007
    Did you follow directions above to email NAT-PMP in Azureus? It worked like a charm for me. It's buried in the UPnP plugin settings, even though they're in fact not related. NAT-PMP is an IETF draft standard protocol for allowing apps to open ports on routers, whereas UPNP is an arbitrary 'standard' set by a forum (including Microsoft) for configuring various devices.

    I haven't tried opening specific ports for other apps yet. I did, however, setup my laptop to always receive the same address from DHCP based on its name, which is the first step.
  13. turkchgo macrumors newbie

    Apr 21, 2007

    All you've done here is put your Mac in a de-militarized zone (also known as a DMZ) which means you've exposed it completely to the bare internet and removed all of it's ports from behind your NAT firewall.

    Of course, if that's what you want to do, more power to ya, but that's not how the Airport is supposed to work.

    Generally the DMZ is for putting sheep out to the slaughter, and usually the devices you put at a defualt host are hardened and not really subject to any remote attackes. I normally put my XBOX as the default host on my LAN because having it totally exposed to the internet really doesn't matter much.

    Your Mac however would now have every service you have open on it exposed to the public.

    The NAT router on the Airport is *supposed* to work by automatically opening 1 port for whatever you're using behind the NAT and 1 port only.

    Apparently this isn't working at all with the new Airport Extreme N.

    Has anyone been able to confirm or not that the NATpmp is not working correctly? Both Azeurus and Transmission fail when trying to use NATpmp with the new Extreme. This worked flawlessly however with the old Extreme basestation.
  14. turkchgo macrumors newbie

    Apr 21, 2007
    Sadly you're doing nothing wrong. Apple for some reason has decided to take 30 years of history and change how it works with this new basestation.

    Port 548 has been Apple Filing Protocol (AFP) forever and normally to access an AppleShare server behind a firewall/NAT you would do so over port 548, however with the new Airport Extreme Basestation N if you have "Airport Disk" turned on then the Airport itself uses this port to share the disk with your network and the internet (if you have outside access turned on) so you will no longer be able to port forward the standard AFP port to computers inside your network.

    To get around this you either need to turn off the AirPort shared disk feature or map a new port (549) as your sharing port for AppleShare/AFP. And then change your connection proceedures on remote machines accordingly (afp:// to connect to your Mac inside your Airport network.

    Here's how I did mine:
  15. aoosten macrumors newbie

    Nov 30, 2007

    Hi Tukchgo

    I followed the previous procedure but your comment got me worried.
    How do you propose to modify this procedure so that my Mac
    is no longer in a DMZ?



  16. kolax macrumors G3

    Mar 20, 2007
    I can open ports no problem with my Airport Extreme (n) for my laptop.

    However, I'm puzzled as to why I can't enter more than one private IP for that specific port?

    I have specified a port for Transmission, and my flatmates have also specified that port. How do I make that port open for all computers?

    Specifying a different port isn't always an option (i.e. one port for one computer, another port for another), as certain games and things only run through a specified port.
  17. terrygin macrumors newbie

    May 4, 2008
    I am having a similiar problem

    all stated here

    Attached Files:

  18. ATragicPortrait macrumors newbie

    Sep 11, 2008
    can anyone tell me how to forward ports on 2WIRE193 so i can host games in warcraft 3??

Share This Page