Airport Express Running Slow

Discussion in 'Mac Accessories' started by mashinhead, Jul 26, 2007.

  1. mashinhead macrumors 68020

    Joined:
    Oct 7, 2003
    #1
    I'm having really slow internet speeds for the last couple days. I know it my airport because i directly connected to the DSL modem and it was blazing. I have no idea why it's so slow. anyone know of any solutions or having the same issue?
     
  2. lancestraz macrumors 6502a

    lancestraz

    Joined:
    Nov 27, 2005
    Location:
    RI
    #2
    Try un-pluging the Airport Express for 30 seconds, then plug it back in and try it.
     
  3. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #3
    Are you getting good reception with it? Are there other machines hooked up to the AirPort network? Do the internet settings for the AirPort match the ethernet settings of your Mac? :)
     
  4. mashinhead thread starter macrumors 68020

    Joined:
    Oct 7, 2003
    #4
    i have to admit the reception hasn't been that great lately 2-3 bars, 4 rare, but it was doing that before it was slow as well. already uplugged it
     
  5. kevinliu4 macrumors regular

    Joined:
    Aug 8, 2006
    #5
    i would also appreciate any useful feedback. i have both a pc and my mbp connected to the airport. the connection is stable but the speed on the mac is terrible whereas on the pc, it is very fast.

    not sure what the problem could be. my airport firmware has just been updated but that didn't help at all.
     
  6. asdf29 macrumors newbie

    Joined:
    Dec 10, 2007
    #6
    Same problem.

    I have the same problem. Anyone work out what is causing it?
     
  7. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #7
    Try changing the broadcast channel to see if you can get better reception for a while.
     

Share This Page