Airport Express to PC - Error 6753

Discussion in 'Mac Accessories' started by TatsuTerror, Apr 19, 2008.

  1. TatsuTerror macrumors regular

    Jan 1, 2008
    Hello everyone,

    I recently purchased two Airport Expresses for my home, which has a Mac and two PC's. I set up the network using Airport Utility, and it works fine on my Macbook Pro and our laptop PC. However, on the desktop, I cannot get the internet to work. The computer recognizes the signal and connects to my network, but the actual internet won't work. I installed AirPort Utility and tried to see what the problem was, but when I press continue, I get "An error occurred while trying to access the Apple wireless device. Make sure your network connection is valid and try again Error -6753"

    I don't know what to make of this, and I'd really appreciate some help, because I need internet on this computer.
  2. jhawkinsvalrico macrumors newbie

    Mar 1, 2010
    I've owned an Airport Express for several years and have been using it succesfully to stream music from iTunes to my receiver. Recently it stopped working and I tried several times to get it working again. The status light was green, but whenever I tried to use the Airport utility I would get an error 6753 from Airport utility when reading the configuration from the Airport Express.

    I am using a Linksys WRT110 wireless router and I couldn't think of what was wrong, so I did the following which corrected the issue:

    1. Downloaded the latest firmware update for the router from the linksys support pages and updated to that version.
    2. I did a complete hard reset on the router and re-configured it.
    3. When configuring the router's wireless security I selected AES/TKIP.

    The Airport Express works fine and I think it has something to do with the security settings. I remembered that awhile ago I had to reconfigure the router and selected WPA/2 and AES, not the AES/TKIP option. It has been awhile, and I don't think that I have used the Airport Express since I made that change. All I know is that it now works, so if you are getting the 6753 error message, you might want to check the wireless security settings on your router.
  3. cosmosis121 macrumors newbie

    Jan 23, 2011
    I just solved error 6753 on my machine. Thought I'd shed some light for any future readers.

    I'm using windows 7 with an older airport express (firmware 6.3).

    After resetting the express (using a pin on the reset button), I could only access it if I manually told my computer to switch networks from my current home network to the airport express network (base station XXXXXX). Afterwards, if I loaded the airport software, I could connect and configure the express.

    When I configured the express to join my current home network, I again ran into problems. The software resetted the device, and even though its light was green, the airport software could no longer connect to it.

    Even more interestingly, when logged into my home router, I saw that the express wasn't connected to the network as I expected it should be.

    Interestingly enough, I fixed it by changing the channel of my home wireless network. I.e.

    (1) Tell my computer to switch back to my proper home network, if it hadn't already.
    (2) Log into my home router (
    (3) Adjust the router settings by assigning a new channel, keeping everything else the same.

    I'm not sure why this solved the problem. I'd guess that the actual channel has nothing to do with it, but changing channels somehow caused the router to reboot, and allowed all devices (including the express) to somehow reconnect properly.

    I see the previous post suggests adjusting wireless router settings to change security types. I`m wondering if, in both circumstances, we forced the router to reboot, which really solved the problem.

    Hope this helps!!!
  4. lamintdog macrumors newbie

    Apr 16, 2011
    Just wanted to say thanks to cosmosis121 for the solution post. It totally worked for me and just saved me tossing this airport express out the window. Changed my router's wireless channel from auto to 11, applied the changes and voila - works like a charm.

    Thank you!

Share This Page