Airport Express via Time Capsule on Wired GB Problem

Discussion in 'Mac Accessories' started by Tom Sawyer, May 19, 2008.

  1. Tom Sawyer macrumors 6502a

    Tom Sawyer

    Joined:
    Aug 29, 2007
    #1
    I've got a very frustrating problem going on. Just picked up an Airport Express for the sole purpose of streaming Audio. Easy setup out of the box, put it in 'bridge' mode, joined my TC wireless network without issue, configured via the Airport Utility, no biggie. All this while connected to my wireless network on my iMac via it's AP card.

    Once everything is configured, I disconnected from the wireless network (turned off airport) and hooked up my GB wired connection to my TC. Faster for backups, access to my server, etc etc. When the iMac is connected via wireless to the network, I can access the AE just fine; but when I switch to wired connection, I can not even get into it via the Airport Utility, just says "Reading the Airport Express Configuration".... forever. Switch from wired to wireless... in with no problem. I've also noticed very slow access (LONG pauses before the AE starts playing or it just wont play) in iTunes when wired vrs wireless. Now my wired connection to my TC is FAST, exactly as you would expect it to be with Gigabit Ethernet. I can copy and pull 2 gig files from my server in less than a minute, so I'm definitely running at excellent GB speed.

    So... anyone have any thoughts or insight on what in the world might be going on with this? If I have to give up my Gigabit connection to my TC to get AE to work, then that is a deal killer (which sucks because I have some Audioengine 5's coming for the AE setup!)...

    Any help is greatly appreciated!
     

    Attached Files:

  2. Batt macrumors 65816

    Batt

    Joined:
    Dec 17, 2007
    Location:
    Syracuse, NY
    #2
    Well, you've confused hell out of me. How do you expect the Express to work if you've turned Airport off?
     
  3. Tom Sawyer thread starter macrumors 6502a

    Tom Sawyer

    Joined:
    Aug 29, 2007
    #3
    LOL... yeah, probably should clarify a bit: I did the INITIAL configuration of the AE with my iMac connected to it wirelessly (since that's how you have to do it initially). Once I told the AE to join my EXISTING network, then it reset and connected right up to my wireless network (again a Time Capsule).

    At that point, I disconnected/disabled my iMacs wireless adapter and moved to the wired gigabit connection...

    I can see the AE just fine in Airport Utility... Just can't do anything with it configuration wise (and again, very poor response time in iTunes, sometimes won't start playing etc).

    This is as far as I can get... when I click Manual config (or Continue) I get the "Reading the Airport Express Configuration" message.

    BTW... can get in and out of my TC config with NO problem.
     
  4. Tom Sawyer thread starter macrumors 6502a

    Tom Sawyer

    Joined:
    Aug 29, 2007
    #4
    Problem SOLVED!

    I figured out what the problem was and it's pretty obscure: Jumbo Frames were causing the issue. I had (since I was using Gigabit ethernet) turned on Jumbo Frames on my iMac and my Server to maximize my performance. What made me realize it is that I started playing with my wifes laptop (and XP box) that's on the wireless network and it could stream to the AE perfectly, very fast response etc. On top of that, after installing the Airport Utility on it, it was able to access and configure the AE with no problem either. So what is so different about my wired than wireless I wondered..... Other than oh I don't know its FASTER... etc.

    Started poking through all the settings and got to the area where I had turned on Manual config on the ethernet card and turned up jumbo frames. Just figured I'd try it on a whim really... and sure enough, put the config back to Automatic and everything worked perfectly!

    Now I stream with INSTANT response (next song, prev song etc)... getting into the config works perfectly etc. Strange thing, you would think that the Time Capsules switch would be able to tell the client (iMac) to throttle back on the Jumbo frames to accomodate a wireless client, but perhaps there is more to it.

    Either way... problem solved! I hope this will help someone out in the future who runs up against the same thing! :D
     

Share This Page