Airport extream+kismac+Injection

Discussion in 'Mac Basics and Help' started by mngngf, Aug 4, 2006.

  1. mngngf macrumors newbie

    Jul 31, 2006
    i got kismac to run on my macbook (non pro) in passave mode and can pick up packets but when i try to do pacet injection it says i dont have a primary injection driver. when i try to set my airport extream to primary injection driver the check box is faded so i cant click it. any downloads to let my air port extream card allow injection:confused: ?

    :) thank you in advance if i dont thank you after:D
  2. toams7 macrumors newbie

    Apr 8, 2008

    no really, i have the same problem
    in the video i was using to do this:

    it has you click authentication flood or something. this gathers packets rapidly. so i clicked and i got "You have no primary injection driver chosen, please select one in the preferences dialog." I have the same faded check box problem.

    i am using iBook G4 12" 800 ghz (first model), with airport extreme. i have KisMAC r75 or something, and i need to hack a WEP. any help????
  3. MacDaddy08 macrumors regular


    Feb 13, 2008
    I don't know an answer to your question but I have one of my own.
    I am running Kismac on a MBP with Leopard. It scans in passive mode but doesn't pick up any packets. Are you using Leopard with your version and if so, what build did you use for Kismac and where did you get it. I can't get mine working.
  4. quest4apple macrumors member

    Apr 3, 2008
    I don't think the current version of KISMAC supports the N cards in the current Macbooks and Macbook Pros. I thought you had to use a USB device to do this type of thing.
  5. MacDaddy08 macrumors regular


    Feb 13, 2008
    I know Kismac supported the Airport Extremes fine if you are running Tiger in both passive and active mode. When you upgrade to leopard however, you lose it. Last i heard they were trying to come up with a new code to make it work with Leopard but that was back in December.

    You can hook up a prism2 USB wireless adapter and it will work fine but you can't use the Airport Extreme in Leopard as far as I know, at least not for passive mode. Nothing to do with the wireless n draft though. Mine is just 802.11 b/g and it doesn't work either.
  6. toams7 macrumors newbie

    Apr 8, 2008
    i found out

    okay, i now have the answers to this whole thread. i got them from the KisMAC FAQ.

    1. If someone asked me if i run leopard, i dont, my machine need 17 more mhz for it to run, boooo hoooo. i have 10.4.11 i think

    2. The only way to get Airport Extreme to work is if you download KisMAC r75, because it didnt go into monitor/passive mode for me at all untiil i used r75. You cant get any packets without passive mode.

    3. If you have airport extreme, or airport, its mostly hopeless, because Airport doesnt and will never inject packets, so you cannot reinject to create more traffic. Im brand new to this so i dont know everything, but i think from what ive read that you need to reinject to crack a WEP. The only way it will work with airport is if you wait for a long time, and there is alot of network traffic.

    4. If you really want this to work, order a Prism2 card, because it says they work best.

    The FAQ can be found at

    Hope this helped:)
  7. MacDaddy08 macrumors regular


    Feb 13, 2008
    Thanks for the reply and sorry I was so late. I just checked it.

    Everything sounds right, I have the latest version of kismac installed but can't run in active/passive mode because I am running Leopard. And yes, you do need to reinject packets to create more traffic in order to crack the WEP faster. Otherwise, as you said, it would take a very long time.

    I found a program that is completely CD bootable and Linux based that I have been messing with for a while. It has all the tools included in it for WPA/WEP cracking. Also all kinds of other stuff for network administration and monitoring. it is really an awesome program and can be booted from your Mac, at least I could from my MBP just by holding option at startup it gave me the option.

    It is called BackTrack 2. You can click here to download it. You have to burn it to CD and boot from it.

    You will need to read instruction on how to use it and all the functions of it. Click here to view how to boot from the CD and an over view of all the tools.

    Here is a walkthrough to crack WEP using backtrack.

    It is a great piece of software for network security evaluation. Once you learn the proper way to use it, the possibilities are endless.
  8. irmatt, May 28, 2008
    Last edited: Nov 8, 2013

    irmatt macrumors newbie

    Jul 26, 2007
  9. toams7 macrumors newbie

    Apr 8, 2008
    thanks so much macdaddy thats really amazing ill try it out soon
    i abandoned the whole thing a while ago but now i cant wait to try this out
    are you sure it works with my specs? (iBookG4withAirportExtreme)

    cant wait
  10. MacDaddy08 macrumors regular


    Feb 13, 2008
    I am not sure 100%. It works fine for me but I am running the Intel based MBP. I have not tried it with a power PC. The only thing I can suggest it to just try it out and hope for the best.

    Good luck!
  11. toams7 macrumors newbie

    Apr 8, 2008
    alright, is burning right now.....
    ive tried running a linux live CD on here before, and it never works, which annoys me because linux is so awesome to mess around with, and it wouldnt boot, and then when i tried to get a Live Knoppix for power pc, it was corrupted....

    this is my last blank CD so after this i guess i will just forget about it again...
  12. toams7 macrumors newbie

    Apr 8, 2008
    sorry it just wont, im so unlucky

    right when i was looking at the list of which cards it supported, and saw that it didnt do airport, my stupid G4 told me "blaa blaa blaa ur disk is unreliable, throw it away and get a new one"

    so unless you can get airport to reinject by wednesday, i wont be interested in this anymore, until next school year......
  13. stump-jumper macrumors newbie

    Jun 18, 2008
    Success with BackTrack 2.0 on MacBook Pro

    Using your lead I was able to crack a WEP password on my 2.16 GHz Intel Core Duo MacBook Pro using BackTrack 2.0 from here.
    After burning the iso to a cd, booting from it by shutting down, inserting the disc, holding the option key down and selecting the "Windows" disc, typing return at the prompt, logging in using root and toor and then typing startx, I followed the directions here almost exactly. The only thing I changed was the channel from 11 to 6. I also had used KisMAC to determine the channel, ssid and bssid of the network to crack. I found this article very useful as reference, especially using macchanger -s wifi0 to get the MAC for my wireless card, but almost none of the commands given worked for me.

    My first try at running aircrack-ng returned some error message indicating I may need more data packets. I captured 100,000 instead of the 70,000 and left both airodump-ng and aireplay-ng running while running aircrack-ng. It took much less than a minute to get the WEP password. I typed the result into MacBooks running Leopard and Tiger as given by aircrack-ng, but had to omit the ":". Leopard took it in the default dialog box, for Tiger I had to use the "WEP 40/128-bit hex" option.
  14. bujisky macrumors newbie

    Feb 26, 2009

    I burn the iso to a CD..reboot and hode the option key ,but there only mac and winxp..NO live CD, what wrong with it ?
  15. marbles macrumors 68000


    Apr 30, 2008
    EU mostly
    I'm using Leopard on a early 09 whitebook [ no bootcamp/windows ] , desperately trying to make KisMac work but keep getting the "You have no primary injection driver chosen, please select one in the preferences dialog." message.

    I read the FAQ's twice and have followed all the steps several times, even reinstalled KisMac a couple times.

    What am doing wrong? Why won't it work ?

    I'm struggling find any decent help info anywhere, have they finished developing this now? , I thought it was all back on now the left Germany
  16. rmitchell macrumors newbie

    Sep 13, 2006
    Hold C instead of Option

    It took me a few reads to figure this out as well. Unless you have one of the very specific injection based wireless adapters you can't inject. Read above in the forum and they go over this.

    The built in Airport card doesn't have the ability to inject.
  17. marbles macrumors 68000


    Apr 30, 2008
    EU mostly
    It is a shame .

    I'm sure I read on the site that they now supported apples built in cards now ....just checked... I must be wrong, or the page has been edited.

    I am needing to test networks , what can I do except for buying an antenna much do those things run in at I knpw nothing about them , have always used built in cards on other machines
  18. Jethryn Freyman macrumors 68020

    Jethryn Freyman

    Aug 9, 2007
    Packet injection under OS X is pretty painful, as is getting Kismac to work without picking up corrupt packets.

    The easiest way is to download the Backtrack live CD and boot from it, and use Kismet/Aircrack/Aireplay. If you have a USB wireless card, you can use it with Parallels or Fusion.
  19. applerocks12 macrumors newbie

    May 30, 2010
    I'm sorry I'm so late but why would you boot from it and what would it do? :apple:

Share This Page